Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153033 - GtkDeprecationWarning: gtk.FALSE, gtk.TRUE
Summary: GtkDeprecationWarning: gtk.FALSE, gtk.TRUE
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firstboot
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
: 153036 (view as bug list)
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2005-04-01 03:16 UTC by Ricky Ng-Adam
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 1.3.42
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-04 23:20:41 UTC


Attachments (Terms of Use)
fixes the warnings (deleted)
2005-04-01 05:31 UTC, Colin Charles
no flags Details | Diff

Description Ricky Ng-Adam 2005-04-01 03:16:02 UTC
Description of problem:

/usr/share/firstboot/firstbootWindow.py:59: GtkDeprecationWarning: gtk.FALSE is
deprecated, use False instead
  self.mainHBox = gtk.HBox(gtk.FALSE, 10)
/usr/share/firstboot/firstbootWindow.py:69: GtkDeprecationWarning: gtk.TRUE is
deprecated, use True instead
  self.leftVBox.pack_start(leftEventBox, gtk.TRUE)
/usr/share/firstboot/firstbootWindow.py:86: GtkDeprecationWarning: gtk.FALSE is
deprecated, use False instead
  self.win.set_decorated(gtk.FALSE)
/usr/share/firstboot/firstbootWindow.py:112: DeprecationWarning: use
gtk.gdk.Drawable.draw_pixbuf
  y_screen, gtk.gdk.RGB_DITHER_MAX, 0, 0)
/usr/share/firstboot/firstbootWindow.py:113: GtkDeprecationWarning: gtk.TRUE is
deprecated, use True instead
  self.win.set_app_paintable(gtk.TRUE)
/usr/share/firstboot/firstbootWindow.py:114: GtkDeprecationWarning: gtk.FALSE is
deprecated, use False instead
  self.win.window.set_back_pixmap(bgimage, gtk.FALSE)
/usr/share/firstboot/firstbootWindow.py:143: GtkDeprecationWarning: gtk.FALSE is
deprecated, use False instead
  self.notebook.set_show_tabs(gtk.FALSE)
/usr/share/firstboot/firstbootWindow.py:144: GtkDeprecationWarning: gtk.TRUE is
deprecated, use True instead
  self.notebook.set_scrollable(gtk.TRUE)
/usr/share/firstboot/firstbootWindow.py:145: GtkDeprecationWarning: gtk.FALSE is
deprecated, use False instead
  self.notebook.set_show_border(gtk.FALSE)

Version-Release number of selected component (if applicable):

1.3.39-3

How reproducible:

always

Steps to Reproduce:
1. start program at console
2.
3.
  
Actual results:

extraneous warnings

Expected results:

no warnings

Additional info:

Most system-config-* have the same problem, I'm opening a bug for each.

Comment 1 Colin Charles 2005-04-01 05:30:37 UTC
Attached patch will fix all the warnings, even in the unused_modules. Please
apply, and rebuild.

Comment 2 Colin Charles 2005-04-01 05:31:12 UTC
Created attachment 112571 [details]
fixes the warnings

Comment 3 Colin Charles 2005-04-01 06:07:19 UTC
*** Bug 153036 has been marked as a duplicate of this bug. ***

Comment 4 Jeremy Katz 2005-05-25 15:00:58 UTC
Fixed in 1.3.42


Note You need to log in before you can comment on or make changes to this bug.