Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153029 - lpstat/lpq does not show status of remote browsed printer
Summary: lpstat/lpq does not show status of remote browsed printer
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-01 00:10 UTC by Orion Poplawski
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-12 12:26:37 UTC


Attachments (Terms of Use)

Description Orion Poplawski 2005-04-01 00:10:50 UTC
Description of problem:

We have a single cups printer server.  Clients learn about the printers via
automatic browsing.  Typical client looks like:

scheduler is running
system default destination: poe
device for angelou: ipp://cynosure:631/printers/angelou
device for frost: ipp://cynosure:631/printers/frost
device for poe: ipp://cynosure:631/printers/poe
device for seuss: ipp://cynosure:631/printers/seuss
angelou accepting requests since Jan 01 00:00
frost accepting requests since Jan 01 00:00
poe accepting requests since Jan 01 00:00
seuss accepting requests since Jan 01 00:00
printer angelou is idle.  enabled since Jan 01 00:00
printer frost is idle.  enabled since Jan 01 00:00
printer poe is idle.  enabled since Jan 01 00:00
printer seuss is idle.  enabled since Jan 01 00:00

Note - the devices used to show up as ipp://earth/

Actually, it looks like they start off with ipp://earth, but then change to
ipp://<localhostname> quickly.  Self browsing?


However, lpstat/lpq should show the status of the queues on the printer server
(earth in this case) as well.

Version-Release number of selected component (if applicable):
cups-1.1.22-0.rc1.8.5

How reproducible:
everytime

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tim Waugh 2005-04-12 12:26:37 UTC
You can use 'lpstat -h ...' for this.


Note You need to log in before you can comment on or make changes to this bug.