Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153008 - journal.c:1982: internal error: Segmentation fault
Summary: journal.c:1982: internal error: Segmentation fault
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gcc3
Version: 3.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-31 21:24 UTC by George R. Goffe
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-01 10:19:53 UTC


Attachments (Terms of Use)
.config file for 29 kernel; product of make oldconfig+26 kernel .config (deleted)
2005-03-31 21:36 UTC, George R. Goffe
no flags Details
complete build log for this problem. (deleted)
2005-03-31 21:37 UTC, George R. Goffe
no flags Details

Description George R. Goffe 2005-03-31 21:24:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
gcc -D__KERNEL__ -I/mnt/hdg1/kernel/linux-2.4.29/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -pipe -mpreferred-stack-boundary=2 -march=athlon  -DMODULE -DMODVERSION
S -include /mnt/hdg1/kernel/linux-2.4.29/include/linux/modversions.h  -nostdinc -iwithprefix include -DKBUILD_BASENAME=journal  -c -o journal.o journal.c
journal.c: In function `presto_journal_link':
journal.c:1982: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[2]: *** [journal.o] Error 1
make[2]: Leaving directory `/mnt/hdg1/kernel/linux-2.4.29/fs/intermezzo'
make[1]: *** [_modsubdir_intermezzo] Error 2
make[1]: Leaving directory `/mnt/hdg1/kernel/linux-2.4.29/fs'
make: *** [_mod_fs] Error 2

Version-Release number of selected component (if applicable):
gcc-3.2.3-49

How reproducible:
Always

Steps to Reproduce:
1.copy my .config file to kernel directory (2.4.29)
2.do the usual pre build stuff (make xconfig; save config)
3.do the usual build (make dep; make bzImage;make modules;make modules_install)
  

Actual Results:  gcc -D__KERNEL__ -I/mnt/hdg1/kernel/linux-2.4.29/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -pipe -mpreferred-stack-boundary=2 -march=athlon  -DMODULE -DMODVERSION
S -include /mnt/hdg1/kernel/linux-2.4.29/include/linux/modversions.h  -nostdinc -iwithprefix include -DKBUILD_BASENAME=journal  -c -o journal.o journal.c
journal.c: In function `presto_journal_link':
journal.c:1982: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[2]: *** [journal.o] Error 1
make[2]: Leaving directory `/mnt/hdg1/kernel/linux-2.4.29/fs/intermezzo'
make[1]: *** [_modsubdir_intermezzo] Error 2
make[1]: Leaving directory `/mnt/hdg1/kernel/linux-2.4.29/fs'
make: *** [_mod_fs] Error 2

Expected Results:  successfull build.

Additional info:

Comment 1 George R. Goffe 2005-03-31 21:36:40 UTC
Created attachment 112543 [details]
.config file for 29 kernel; product of make oldconfig+26 kernel .config

Comment 2 George R. Goffe 2005-03-31 21:37:46 UTC
Created attachment 112544 [details]
complete build log for this problem.

Comment 3 Jakub Jelinek 2005-04-01 10:19:53 UTC
The compiler detected that the segfault is not reproduceable (in case of
internal error attempts to retry 3 times).
Unless you can reproduce this always on the same file same error, it is in
all cases I have seen reported so far a hardware problem (bad memory, bad
cooling, etc.).

Comment 4 George R. Goffe 2005-04-01 21:38:46 UTC
Jakub,

I find it VERY DIFFICULT to believe that this is a hardware problem since the
compiler is the ONLY program I'm having troubles with. Can you explain how this
could be please?

Regards,

George...


Comment 5 Jakub Jelinek 2005-04-01 23:06:33 UTC
GCC is a deterministic program, so for the same input and same options should
always give the same result.  If that is not the case, a hardware problem is
the single most common cause (just google for sig11 gcc, I remember dozens of
such reported bugs that were later confirmed to be hardware problems).
The fact that you don't have problems with other programs doesn't count, GCC
memory usage pattern is very specific and there are bugs you happen to hit only
in certain type of usage patterns.
No matter what, if we are unable to reproduce the problem and you can't either,
even if it was a software problem, it is not possible to debug it.


Note You need to log in before you can comment on or make changes to this bug.