Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153005 - IIIM does not work with Motif apps
Summary: IIIM does not work with Motif apps
Keywords:
Status: CLOSED DUPLICATE of bug 141298
Alias: None
Product: Fedora
Classification: Fedora
Component: iiimf
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-31 20:38 UTC by Felipe Heidrich
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-04 12:24:20 UTC


Attachments (Terms of Use)

Description Felipe Heidrich 2005-03-31 20:38:35 UTC
Fedora Core 3

Description of problem:

I can't get IIIM to work with Motif. (Tested with OpenMotif 2.1 and 2.2)
I'm specially trying to get Japanese IM working.

How reproducible:

Set your IIIM up and running, run a motif application, try to use the IM.
Nothing happens.

I had to problem to get kinput2 to work, I just started kinput2 -canna;
XMODIFIERS=@im=kinput2 ./myMotifApp

Isn't IIIM supposed to work with Motif?
Here is a motif app code:
#include <Xm/XmAll.h>
#include <stdio.h>
#include <X11/Xlib.h>
#include <X11/Xlocale.h>
#include <locale.h>


int main(int argc, char **argv) {
	Display* xDisplay;
    XtAppContext xtContext;
    Widget shell, text;
    XmFontList fontList;
    XmFontListEntry fontListEntry;

	setlocale(LC_ALL, "");
	XtToolkitInitialize();	
	xtContext = XtCreateApplicationContext();
	XtSetLanguageProc (xtContext, NULL, NULL);		
	xDisplay = XtOpenDisplay(xtContext, NULL,  NULL, NULL,0, 0, &argc, argv);
	
	shell = XtAppCreateShell (NULL, NULL, topLevelShellWidgetClass, xDisplay, NULL,0 );
	text = XmCreateTextField(shell, NULL, NULL, 0);
	XtManageChild(text);
	
	fontListEntry = XmFontListEntryLoad(xDisplay, "*", XmFONT_IS_FONTSET,
XmFONTLIST_DEFAULT_TAG);	
	fontList = XmFontListAppendEntry(NULL, fontListEntry);
	XmFontListEntryFree(&fontListEntry);	
	XtVaSetValues (text, XmNfontList, fontList, NULL);

	/*Main Loop*/
	XtResizeWidget (shell, 280, 80, 0);
	XtRealizeWidget (shell);
	XtAppMainLoop(xtContext);
	return 0;
}

Comment 1 Felipe Heidrich 2005-03-31 20:41:21 UTC
I meant to say:
I had *NO* problem to get kinput2 to work

Comment 2 Akira TAGOH 2005-04-01 01:49:21 UTC
Please make sure that you got httx running and XMODIFIERS=@im=htt.


Comment 3 Felipe Heidrich 2005-04-01 17:28:34 UTC
Okay, now I know why I was having different result. I said the IM was not being
loaded by motif, this is true. Except by the first time I ran the application,
when it did loaded the IM, but it crashed when I tried to use it. When it
crashed it killed this httx process.
Here the steps to reproduce the crash:
1. export XMODIFIERS=@im=htt
2. httx &
3. ./myMotifApp
- At this point motif loads the IM, the IM status window is at the bottom of the
main window, all looks normal
4. Ctrl+Space [open the IM]
Warnings:
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  154 (RENDER)
  Minor opcode of failed request:  4 (RenderCreatePicture)
  Resource id in failed request:  0x0
  Serial number of failed request:  224
  Current serial number in output stream:  235
htt : Warning - htt_server has been terminated without knowledge of htt ,
restart htt again
5. press any key or give the focus to other window and then back to motif window
and it crashes.
[1]+  Done                    httx
Segmentation fault


Comment 4 Akira TAGOH 2005-04-04 12:24:20 UTC
It looks like the same problem to Bug#141298. closing as DUPLICATED.

*** This bug has been marked as a duplicate of 141298 ***


Note You need to log in before you can comment on or make changes to this bug.