Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153002 - Logical volumes no longer group disk or g+rw in RHEL4
Summary: Logical volumes no longer group disk or g+rw in RHEL4
Keywords:
Status: CLOSED DUPLICATE of bug 141050
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Alasdair Kergon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-31 19:58 UTC by Need Real Name
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-03-31 21:38:32 UTC


Attachments (Terms of Use)

Description Need Real Name 2005-03-31 19:58:50 UTC
Description of problem:

In RHEL3 my logical volumes looked like:

ls -l /dev/Volume00/
total 0
brw-rw----    1 root     disk      58,   5 Dec 18 11:14 LogVol00
brw-rw----    1 root     disk      58,   0 Dec 18 11:14 LogVol01
brw-rw----    1 root     disk      58,   2 Dec 18 11:14 LogVol02
brw-rw----    1 root     disk      58,   3 Dec 18 11:14 LogVol03
brw-rw----    1 root     disk      58,   4 Dec 18 11:14 LogVol04
brw-rw----    1 root     disk      58,   1 Dec 18 11:14 LogVol05
crw-r-----    1 root     disk     109,   0 Dec 18 11:14 group

Now on a RHEL 4 system:

# ls -l /dev/mapper/
total 0
crw-------  1 root root  10, 63 Feb 23 09:55 control
brw-------  1 root root 253,  4 Feb 23 09:55 VolGroup00-LogVol00
brw-------  1 root root 253,  0 Feb 23 09:55 VolGroup00-LogVol01
brw-------  1 root root 253,  2 Feb 23 09:55 VolGroup00-LogVol02
brw-------  1 root root 253,  3 Feb 23 09:55 VolGroup00-LogVol03
brw-------  1 root root 253,  1 Feb 23 09:55 VolGroup00-LogVol04

This has the effect of breaking amanda as it its gid is disk and it needs at
least read permissions on the filesystem to use dump as uid/gid amanda/disk.

Version-Release number of selected component (if applicable):

lvm2-2.00.31-1.0.RHEL4

I'm filing this against lvm2 although perhaps anaconda would be better

How reproducible:

Always

Steps to Reproduce:
1. Install a new system with logical volumes
2. ls -l /dev/mapper
3.
  
Actual results:

ls -l /dev/mapper
total 0
crw-------  1 root root  10, 63 Feb 23 09:55 control
brw-------  1 root root 253,  4 Feb 23 09:55 VolGroup00-LogVol00
brw-------  1 root root 253,  0 Feb 23 09:55 VolGroup00-LogVol01
brw-------  1 root root 253,  2 Feb 23 09:55 VolGroup00-LogVol02
brw-------  1 root root 253,  3 Feb 23 09:55 VolGroup00-LogVol03
brw-------  1 root root 253,  1 Feb 23 09:55 VolGroup00-LogVol04


Expected results:

Something like RHEL3's:

ls -l /dev/Volume00/
total 0
brw-rw----    1 root     disk      58,   5 Dec 18 11:14 LogVol00
brw-rw----    1 root     disk      58,   0 Dec 18 11:14 LogVol01
brw-rw----    1 root     disk      58,   2 Dec 18 11:14 LogVol02
brw-rw----    1 root     disk      58,   3 Dec 18 11:14 LogVol03
brw-rw----    1 root     disk      58,   4 Dec 18 11:14 LogVol04
brw-rw----    1 root     disk      58,   1 Dec 18 11:14 LogVol05
crw-r-----    1 root     disk     109,   0 Dec 18 11:14 group

Additional info:

Is there any risk in me chgrp-ing/chmod-ing the devices by hand on RHEL4 so that
amanda will work again?

Comment 1 Alasdair Kergon 2005-03-31 21:38:32 UTC
Fixed by new device-mapper package in update 1.

Yes, until then, you can add commands to /etc/rc.local to chgrp/chmod them.
'control' is OK as it is - only root ever uses it.


*** This bug has been marked as a duplicate of 141050 ***


Note You need to log in before you can comment on or make changes to this bug.