Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153001 - UNIX_ST_LINK should be disabled in kpathsea, or ...
Summary: UNIX_ST_LINK should be disabled in kpathsea, or ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: tetex
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-31 19:47 UTC by Ling Li
Modified: 2013-07-02 23:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-04 17:42:45 UTC


Attachments (Terms of Use)

Description Ling Li 2005-03-31 19:47:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Description of problem:
This is a known bug, see http://www.tug.org/texinfohtml/kpathsea.html#Unable-to-find-files, the 3rd bullet. 

To repeat briefly, if a directory d being searched for subdirectories contains plain files and symbolic links to other directories, but no true subdirectories, d will be considered a leaf directory, i.e., the symbolic links will not be followed. You can work around this problem by creating an empty dummy subdirectory in d. Then d will no longer be a leaf, and the symlinks will be followed.

I haven't looked at the actual code for this part, but there is one line in this page http://www.tug.org/texinfohtml/kpathsea.html#Subdirectory-expansion reading "You can disable the trick by undefining UNIX_ST_LINK in kpathsea/config.h. (It is undefined by default except under Unix.)" So I guess the quick fix is to disable UNIX_ST_LINK on Fedora Core.

However, if the search performance is the main concern, the code for kpathsea has to be modified. I don't have a solution.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See the description
  

Additional info:

Comment 1 Jindrich Novy 2005-04-01 08:00:23 UTC
I'm not sure whether the undefinition of UNIX_ST_LINK will help somehow as I
grepped all teTeX sources, including kpathsea and found no checks or definitions
of this macro in teTeX-3.0 and teTeX-2.0.2 at all.

I found the UNIX_ST_LINK macro is only noted in the documentation...

Comment 2 Jindrich Novy 2005-05-04 17:42:45 UTC
Ok, closing NOTABUG, because of teh reason in comment #1.


Note You need to log in before you can comment on or make changes to this bug.