Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 152989 - Missing prereqs in rpms
Summary: Missing prereqs in rpms
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-31 18:29 UTC by Thomas Woerner
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-03-31 18:46:16 UTC


Attachments (Terms of Use)
This patch fixes the prereqs: Going back to old RPMSENSE_PREREQ value. (deleted)
2005-03-31 18:37 UTC, Thomas Woerner
no flags Details | Diff

Description Thomas Woerner 2005-03-31 18:29:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041216 Firefox/1.0 Fedora/1.0-6

Description of problem:
All packages built with rpm-4.4 and up do not mark prereqs as prereqs. This can result in wrong loop breakup in dependency loops, because it is not visible if the  removal of a relation will break pre scripts.

An example for this is module-init-tools, which has a prereq for coreutils. Both packages are in a dependency loop. If the dependency for coreutils will be removed from module-init-tools to breakup this loop, this will lead in an install error and maybe more problems.

Version-Release number of selected component (if applicable):
rpm-4.4.1-8

How reproducible:
Always

Steps to Reproduce:
1. Compare rpms from fc3 and fc4 (example: module-init-tools)
2.
3.
  

Actual Results:  No prereqs

Additional info:

Comment 1 Thomas Woerner 2005-03-31 18:37:20 UTC
Created attachment 112529 [details]
This patch fixes the prereqs: Going back to old RPMSENSE_PREREQ value.

Comment 2 Thomas Woerner 2005-03-31 18:46:16 UTC
Fixed in rawhide in rpm rpm-4.4.1-9 or newer.

Comment 3 Mike McLean 2005-03-31 19:24:07 UTC
Given that jbj has repeatedly asserted that prereqs are ignored, I wonder if
this change is appropriate.


Note You need to log in before you can comment on or make changes to this bug.