Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 152968 - sdiff: subsidiary program $EDITOR failed
Summary: sdiff: subsidiary program $EDITOR failed
Keywords:
Status: CLOSED DUPLICATE of bug 152967
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: diffutils
Version: 3.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-31 14:59 UTC by Rangan Chidambara Kuttalam Pillai
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-03-31 15:00:58 UTC


Attachments (Terms of Use)

Description Rangan Chidambara Kuttalam Pillai 2005-03-31 14:59:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.4) Gecko/20050318 Red Hat/1.4.4-1.3.5

Description of problem:
sdiff shows the following error while making changes using the editor.

sdiff: subsidiary program `$EDITOR` failed


Version-Release number of selected component (if applicable):
diffutils-2.8.1-8

How reproducible:
Always

Steps to Reproduce:
1.echo hello >a; echo bye >b 
2.sdiff -o new a b 
3.Then enter 'eb' at % prompt.  This will bring up $EDITOR. 
4.Save, quit. 


Actual Results:  sdiff displays the following error.

sdiff: subsidiary program `$EDITOR` failed

Expected Results:  No error messages.

Additional info:

This bug has been already reported in gnu mailing list.

http://lists.gnu.org/archive/html/bug-gnu-utils/2003-01/msg00121.html 

Also a patch available at the URL
I tested the patch locally and it seem to resolve the problem.

Comment 1 Tim Waugh 2005-03-31 15:00:58 UTC

*** This bug has been marked as a duplicate of 152967 ***


Note You need to log in before you can comment on or make changes to this bug.