Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 152945 - Useful XkbRules option removed by yum update
Summary: Useful XkbRules option removed by yum update
Keywords:
Status: CLOSED DUPLICATE of bug 142429
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-31 05:01 UTC by dann
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-08 19:04:41 UTC


Attachments (Terms of Use)

Description dann 2005-03-31 05:01:02 UTC
Description of problem:
xorg-x11-6.8.2-1.FC3.13 deleted useful stuff from my xorg.conf

I have a SUN type6 USB keyboard, I have 
        Option          "XkbRules"      "sun"
in xorg.conf so that everything works OK with the keyboard (i.e. Meta is Meta,
Alt is Alt, etc)
After doing a yum update an restarting X today I dicovered that the 
Alt and Meta keys were not working properly. 
The cause was that the XkbRules line was removed from my xorg.conf by the
upgrade, it seems that this pre-install script is the cause:
 
        # Remove any Options "XkbRules" lines that may be present
        perl -p -i -e 's/^.*Option.*"XkbRules".*\n$//gi' $configfile
  
Please don't remove useful configuration without any warning.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-1.FC3.13

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Mike A. Harris 2005-04-08 19:01:54 UTC
This problem was recently fixed in rawhide by limiting the scope of
what gets removed to "(xfree86|xorg)" in the scriptlet.  It will
be in all future FC devel builds, as well as any future FC3 or RHEL4
erratum we might release.



Comment 2 Mike A. Harris 2005-04-08 19:04:41 UTC

*** This bug has been marked as a duplicate of 142429 ***


Note You need to log in before you can comment on or make changes to this bug.