Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 152943 - Using lvm on 64-bit version of linux causes driver upgrades on 3ware 9500 series to render RAID array unaccessible
Summary: Using lvm on 64-bit version of linux causes driver upgrades on 3ware 9500 ser...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: lvm2
Version: 3
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Alasdair Kergon
QA Contact:
URL: http://3ware.com/KB/kb.asp
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-31 04:11 UTC by Bob Kuo
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-08 15:12:11 UTC


Attachments (Terms of Use)

Description Bob Kuo 2005-03-31 04:11:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
I currently have the 64-bit version of Fedora Core 3 installed, and I'm using a 3ware 9500S-12 RAID controller with LVM. According to the 3ware website (search for "LVM" or article 13297 in the knowledgebase), if you try to update their driver with this combination (64-bit Linux with LVM), the RAID array will become unusable.

I haven't actually tried to update my 3ware driver because I don't want to lose access to my RAID array. I have contacted 3ware customer support and they say that it is a Linux bug.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Have a 64-bit version of Linux, a 3ware controller card, and LVM
2.Try to upgrade the driver


Actual Results:  I haven't tried it myself.

Expected Results:  The driver should update and the RAID should still be accessible.

Additional info:

Comment 1 Alasdair Kergon 2005-03-31 13:43:36 UTC
Sorry, but this is too vague.

What exactly fails?
What error messages?

Which driver?   3ware 9xxx SATA-RAID support (3w-9xxx)?

Are mkinitrd options being used to include the module?


Comment 2 Bob Kuo 2005-03-31 19:38:26 UTC
I apologize for the vagueness. It's hard for me to provide details since I 
haven't tried to replicate the bug on my system, and I'm only going off of a 
report from the 3ware website. I was hoping 3ware had submitted a bug report 
when I first checked Bugzilla.

In any case, I will contact 3ware technical support again and refer them to 
this bug to see if they can provide more details.

Comment 3 Alasdair Kergon 2005-08-08 15:12:11 UTC
Please reopen when you receive clarification.


Note You need to log in before you can comment on or make changes to this bug.