Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 152941 - USB not found with kernel 2.6.10-1.770_FC3
Summary: USB not found with kernel 2.6.10-1.770_FC3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL: USB not found with x84_64 kernel 2.6...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-31 03:24 UTC by Donald L. Walters
Modified: 2015-01-04 22:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-28 08:10:12 UTC


Attachments (Terms of Use)

Description Donald L. Walters 2005-03-31 03:24:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
USB devices flash, printer, wireless, are not found with
Fedora core 3 x84_64 with kernel 2.6.10-1.770_FC3.
Using an SN25P with Nforce 4 chipset

sda1 is not found in harware search for a flash drive

However, USB devices work fine when I boot with the original download kernel 2.6.9-1.667.



Version-Release number of selected component (if applicable):
2.6.10-1.770_FC3

How reproducible:
Always

Steps to Reproduce:
1. Boot into 2.6.10-1.770_FC3 and the USB flash LED never blinks and sda1 is not seen
2. Boot into 2.6.9-1.667 and the USB flash LED blinks and sda1 is seen and everything works
3.
  

Actual Results:  Using root:       mount -t vfat /dev/sda1 /mnt/flash
System responds:  mount: special device /dev/sda1 does not exist


Expected Results:  should not have to mount the device. It should be found as soon as plugging it in.  It is turned on in the Preference dialog and everything is ok with kernel 2.6.9-1.667

Additional info:

Using Nvidia NFORCE-Linux-x86_64-1.0-0301-pkg1.run chipset drivers
Marvel 88E1111 ethernet chipset

Comment 1 Sitsofe Wheeler 2005-03-31 07:40:06 UTC
Is there anything mentioned in dmesg? Does booting with pci=routeirq help?

Comment 2 Donald L. Walters 2005-03-31 22:30:22 UTC
dmseg  relevant in part:

ACPI: PCI Interrupt Link [APSJ] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [APCP] (IRQs 20 21 22 23) *0, disabled.
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Using ACPI for IRQ routing
** PCI interrupts are no longer routed automatically.  If this
** causes a device to stop working, it is probably because the
** driver failed to call pci_enable_device().  As a temporary
** workaround, the "pci=routeirq" argument restores the old
** behavior. 

SCSI subsystem initialized

usbcore: registered new driver hiddev
usbcore: registered new driver usbhid

I can sent the whole dmseg if you like and give me an address

Comment 3 Claudio Tibaldi 2005-04-05 21:46:22 UTC
Same problem but kernel x86_32. Only usb in rear pannel work. The usb added
inside  internal connector on motherboard a8n-sli (nforce 4) do not recognize
anything.
All functions are properly working with first kernel included in original set.

Comment 4 Sitsofe Wheeler 2005-04-06 20:30:26 UTC
Comment #2 I'd rather not have a full dmesg but er, thanks for asking.

Did booting with pci=routeirq help?

Comment 5 Dave Jones 2005-06-04 07:15:48 UTC
two possibilities..

http://people.redhat.com/davej/kernels/Fedora/FC3/ hsa the next 2.6.11 based
test kernel

http://people.redhat.com/davej/kernels/test/ has a more experimental backport of
the FC4 kernel to FC3. (Though this has had little to no testing at all yet, so
be careful).

Comment 6 Dave Jones 2005-07-15 20:16:28 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.


Note You need to log in before you can comment on or make changes to this bug.