Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 152939 - rpmdb: unable to initialize mutex: Function not implemented
Summary: rpmdb: unable to initialize mutex: Function not implemented
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-31 02:42 UTC by Ricky Ng-Adam
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-28 01:17:25 UTC


Attachments (Terms of Use)

Description Ricky Ng-Adam 2005-03-31 02:42:15 UTC
Description of problem:

Worrisome warning console 1 (ALT-F1):

rpmdb: unable to initialize mutex: Function not implemented
rpmdb: /var/lib/rpm__db.001: unable to initialize environment lock: Function not
 implemented

Version-Release number of selected component (if applicable):

anaconda-runtime-10.2.0.36

How reproducible:

?

Steps to Reproduce:
1. pxe boot
2. kickstart install
3. ALT-F1 to look at consoles during packages install
  
Actual results:

warning on console 1 about rpmdb

Expected results:

no warnings

Additional info:

Comment 1 Peter Jones 2005-03-31 19:06:13 UTC
This is actually what glibc prints when you try to use futex locks without
tls/nptl libc, iirc.

I _think_ this is something rpmlib should be checking for and not using, but it
may be that glibc provides no way to do that.

Comment 2 Jeff Johnson 2005-03-31 19:17:57 UTC
Checking is the easy part, been in rpm since RHL 9.

What to do after that is what is hard ...

Comment 3 Paul Nasrat 2005-04-04 09:38:11 UTC
Original poster - can you expand the stage2 image and see if /lib/tls exists and
if so what is in there.

Comment 5 Ricky Ng-Adam 2005-04-08 03:06:25 UTC
if I do a find / -name "*tls*" during install I get:

/mnt/sysimage/usr/lib/tls
/mnt/sysimage/usr/X11R6/lib/tls
/mnt/sysimage/lib/tls

But thats pretty much it.  No /lib/*tls*...

Comment 6 bcling 2005-04-19 07:26:23 UTC
Install on FC4test2 with NFS install (ISO mounted loopback on second machine,
booted install machine, a Dell 600m, with FC4test2 boot.iso).  At some point
after the mid-point (walked away) but before installing grub, the installer
crashed to yield this similar message...

---

/usr/lib/anaconda/gui.py:447: GtkWarning: Unable to locate theme engine in
module_path: "clearlooks",
  p = gtk.Image()
rpmdb: unable to initialize mutex: Function not implemented
rpmdb: /var/lib/rpm/__db.001: module to initialize environment lock: function
not implemented
install exited abnormally

<you know the rest of the story>

Comment 7 Jeremy Katz 2005-04-28 01:17:25 UTC
Done now I think


Note You need to log in before you can comment on or make changes to this bug.