Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 152932 - application mixer_applet2 uses obsolete OSS audio interface
Summary: application mixer_applet2 uses obsolete OSS audio interface
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-applets
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
: 177999 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-03-31 01:36 UTC by sangu
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-31 14:01:07 UTC


Attachments (Terms of Use)
preference on mixer_applet2 (deleted)
2006-01-25 11:43 UTC, sangu
no flags Details

Description sangu 2005-03-31 01:36:47 UTC
Description of problem:
in dmesg
[...]
application mixer_applet2 uses obsolete OSS audio interface

Version-Release number of selected component (if applicable):
gnome-media-2.10.0-2

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
gstreamer-0.8.9-4, gstreamer-plugins-0.8.8-2, kernel-2.6.11-1.1208_FC4

Comment 1 Ray Strode [halfline] 2005-08-31 17:29:03 UTC
Hi Sangu,

As far as I know the volume control applet uses gstreamer and not OSS (or alsa)
directly.

What makes you think it uses OSS?

Comment 2 Joachim Frieben 2005-09-29 11:39:29 UTC
I am not Sangu ;) but I have seen the same. Just grep "dmesg" for "OSS",
and the following should turn up:

  "application mixer_applet2 uses obsolete OSS audio interface"

BTW, this is not the only application which triggers this message in
"dmesg". See, e.g.,

  "application epiphany uses obsolete OSS audio interface"

in the same log file. It is of course possible, that these messages
are erroneous, but they are clearly present (observed on FC5/rawhide
and earlier releases).

Comment 3 Ian Shields 2006-01-10 04:56:40 UTC
I see this bug too on an ASUS A8N-E Motherboard with a 64-0bit FC4 (currently at
kernel 2.6.14-1.1656_FC4. 

Comment 4 sangu 2006-01-25 11:43:57 UTC
Created attachment 123663 [details]
preference on mixer_applet2

preference has two mixer(Alsa and OSS).

Comment 5 sangu 2006-01-25 11:54:04 UTC
$rpm -q --changelog gnome-media
[...]
* Tue Oct 19 2004 Colin Walters <walters@redhat.com> 2.8.0-2
- Add patch to not show oss mixers

but mixer_applet2 has two mixer.

Comment 6 Ray Strode [halfline] 2006-01-27 21:22:46 UTC
*** Bug 177999 has been marked as a duplicate of this bug. ***

Comment 7 sangu 2006-01-31 14:01:07 UTC
this problem was fixed in gnome-media-2.13.91-1 and gnome-applets-2.13.3-2.



Note You need to log in before you can comment on or make changes to this bug.