Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 152927 - dead keys don't work
Summary: dead keys don't work
Keywords:
Status: CLOSED DUPLICATE of bug 130851
Alias: None
Product: Fedora
Classification: Fedora
Component: iiimf
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-30 23:40 UTC by Felipe Heidrich
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-04 06:34:10 UTC


Attachments (Terms of Use)

Description Felipe Heidrich 2005-03-30 23:40:13 UTC
dead keys don't work on my FC3, running on Gnome.

I set my keyboard to brazilian ABNT2, does not matter if I use system-config-
keyboard or setxkbmap to do the work. I type ' ` " ^ and nothing happens. ' 
followed e gives me e instead of é.
I also tried different keyboard layouts (german, english internatinal), I 
could not get dead keys to work.

So I changed my system to run IIIM on level 5, put the new input method 
switcher up in the bottom panel. Using that I set my input to Latin (unitle), 
now when I hit ' it opens a floating window with a list of option. This is 
horrible, my whole life I used ' followed by e to get é, now I suppose to 
hit ', wait a list to come up, then type the number of the option I want. Even 
worse, the option I want (é) is not in the list!

That is how input method is supposed to work now ? I'm missing something 
simple ?

Thanks

Comment 1 Leon Ho 2005-03-31 06:40:52 UTC
Will deadkeys work again if you stop the iiim service? If yes that is duplicate
of bug 130851.

*** This bug has been marked as a duplicate of 130851 ***

Comment 2 Felipe Heidrich 2005-03-31 16:51:24 UTC
No, it will not.

Comment 3 Akira TAGOH 2005-04-01 06:43:02 UTC
Erm, so even if you did service iiim stop as root, the dead key still doesn't
work? It sounds like you have a problem in xorg.conf. and this isn't an IIIMF
bug since this problem happened without IIIMF.

Comment 4 Felipe Heidrich 2005-04-01 18:07:44 UTC
I got dead keys to work on X/Motif/GTK. I had to stop the iiim server and 
unset GTK_IM_MODULE and XMODIFIERS.
You can close this as dup of bug130851



Comment 5 Akira TAGOH 2005-04-04 06:34:10 UTC
Thank you for your confirmation. closing.

*** This bug has been marked as a duplicate of 130851 ***


Note You need to log in before you can comment on or make changes to this bug.