Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1528859 - [RHV][Graph Refresh] "Archived" Hosts are displayed several times on CFME, with Power state: ON ("Running")
Summary: [RHV][Graph Refresh] "Archived" Hosts are displayed several times on CFME, wi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Piotr Kliczewski
QA Contact: Angelina Nikiforova
URL:
Whiteboard: rhev:graph refresh:host refresh
Depends On:
Blocks: 1532255 1532332
TreeView+ depends on / blocked
 
Reported: 2017-12-24 16:41 UTC by Ilanit Stein
Modified: 2019-04-02 08:24 UTC (History)
10 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1532332 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:02:53 UTC
Category: Bug
Cloudforms Team: RHEVM
Target Upstream Version:


Attachments (Terms of Use)
evm.log (deleted)
2017-12-24 16:41 UTC, Ilanit Stein
no flags Details
automation.log (deleted)
2017-12-24 16:42 UTC, Ilanit Stein
no flags Details
rhevm.log (deleted)
2017-12-24 16:42 UTC, Ilanit Stein
no flags Details
host_with_3_archived_hosts_displayed.png (deleted)
2017-12-24 16:47 UTC, Ilanit Stein
no flags Details
host_with_2_archived_hosts_displayed.png.png (deleted)
2017-12-24 16:48 UTC, Ilanit Stein
no flags Details


Links
System ID Priority Status Summary Last Updated
Github ManageIQ manageiq-providers-ovirt pull 189 None None None 2018-01-05 13:12:33 UTC
Github ManageIQ manageiq pull 16750 None None None 2018-01-05 15:13:18 UTC
Github ManageIQ manageiq pull 16767 None None None 2018-01-09 08:17:28 UTC
Red Hat Bugzilla 1510053 None CLOSED CFME with RHV Graph refresh turned ON - RHV Datastores are displayed multiple times. 2019-01-23 17:06:33 UTC

Internal Links: 1510053

Description Ilanit Stein 2017-12-24 16:41:09 UTC
Description of problem:
CFME-5.9.0.14 connected to a Scale RHV-4.2.1, with ~1800 VMs, and ~400 Hosts,
CFME UI, under Compute->Infrastructure->Hosts:
Each host has several additional occurrences, except for the host, active in RHV.
These additional hosts are of type "Archived".
In their details page,their Power state is: On (These hosts are displayed also under the "Running" hosts filter).
This is a different behavior, compared to CFME-5.8.3, where there are no such "Archived" hosts displayed

Instead of 408 hosts, 1632 hosts are displayed under Compute->Infrastructure->Hosts. 

Version-Release number of selected component (if applicable):
CFME-5.9.0.14
4.2.1-0.0.master.20171206161426.git88e9120.el7.centos

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
The "Archived" hosts number seem to be related to the amount of time the CFME was disconnected from the same Scale RHV.
IIRC, there were 3 disconnections, though for some of the hosts there are 2 "Archived" hosts displayed, and for some hosts, 3 "Archived" hosts displayed.

Comment 2 Ilanit Stein 2017-12-24 16:41:40 UTC
Created attachment 1371914 [details]
evm.log

Comment 3 Ilanit Stein 2017-12-24 16:42:05 UTC
Created attachment 1371915 [details]
automation.log

Comment 4 Ilanit Stein 2017-12-24 16:42:31 UTC
Created attachment 1371916 [details]
rhevm.log

Comment 5 Ilanit Stein 2017-12-24 16:47:47 UTC
Created attachment 1371917 [details]
host_with_3_archived_hosts_displayed.png

Comment 6 Ilanit Stein 2017-12-24 16:48:11 UTC
Created attachment 1371918 [details]
host_with_2_archived_hosts_displayed.png.png

Comment 7 Oved Ourfali 2017-12-25 06:15:29 UTC
Is it a result of adding and removing the provider over and over again? Or each test was done on a new instance of CFME?

Comment 8 Ilanit Stein 2017-12-25 07:47:35 UTC
It is for sure a result of adding and removing the RHV provider, several time from the same CFME. 

I just retested it:
I removed the RHV, and added it back, and now the number of hosts had increased to 2040 =
1632(The previous number of Hosts, including all the "Archived" ones) + 
408(The actual number of hosts on RHV).

Comment 9 Oved Ourfali 2017-12-25 07:53:42 UTC
(In reply to Ilanit Stein from comment #8)
> It is for sure a result of adding and removing the RHV provider, several
> time from the same CFME. 
> 
> I just retested it:
> I removed the RHV, and added it back, and now the number of hosts had
> increased to 2040 =
> 1632(The previous number of Hosts, including all the "Archived" ones) + 
> 408(The actual number of hosts on RHV).

So as far as I know this is by design.
Moti - do you remember?

Comment 10 Moti Asayag 2017-12-25 08:04:34 UTC
(In reply to Oved Ourfali from comment #9)
> (In reply to Ilanit Stein from comment #8)
> > It is for sure a result of adding and removing the RHV provider, several
> > time from the same CFME. 
> > 
> > I just retested it:
> > I removed the RHV, and added it back, and now the number of hosts had
> > increased to 2040 =
> > 1632(The previous number of Hosts, including all the "Archived" ones) + 
> > 408(The actual number of hosts on RHV).
> 
> So as far as I know this is by design.
> Moti - do you remember?

I don't recall the behavior of removed hosts in the system.
I'd expect it to be the same as for other providers.

Ilanit, could you test the same with VMware provider ?

Comment 11 Ilanit Stein 2017-12-25 09:49:21 UTC
Important info:
The bug was reported for CFME-5.9.0.14 + RHV Graph refresh - ON

The behavior of accumulating more hosts, further to each RHV removal & add,
DO NOT occur on CFME-5.9.0.14 + RHV Graph refresh - OFF.
It was tested by the following steps:

1. CFME was moved to RHV Graph refresh - OFF (in settings.yml).
2. CFME showed 2040 hosts (408 that exist on RHV + Archived hosts),
3. RHV was removed, and added back:
4. CFME showed 2040 hosts - the number of hosts remained, same as it was on      
   previous RHV connection.
5. Again RHV was removed, and added back - the number of hosts remained, same as  
   it was on previous RHV connection.

Comment 12 Ilanit Stein 2017-12-26 08:08:15 UTC
Need info for testing the hosts display on VMWare was removed since the bug was proven as Graph Refresh Specific,
and not occurring for RHV provider, without Graph refresh.

Comment 14 Piotr Kliczewski 2018-01-05 13:19:58 UTC
Ilanit, I noticed that host status is the same for both refresh types. I suggest to open new BZ to cover only status.

Comment 16 CFME Bot 2018-01-08 13:35:57 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/2ede836323c8d0fbe48fe1648bda0f14b2314101

commit 2ede836323c8d0fbe48fe1648bda0f14b2314101
Author:     Piotr Kliczewski <piotr.kliczewski@gmail.com>
AuthorDate: Fri Jan 5 16:06:32 2018 +0100
Commit:     Piotr Kliczewski <piotr.kliczewski@gmail.com>
CommitDate: Mon Jan 8 11:54:59 2018 +0100

    Reconnect host on provider add
    
    We need to make sure that when we remove a provider and add it again we
    will keep using the same host entities. Without this change add and remove
    provider cause to duplicate hosts.
    
    Fixes https://bugzilla.redhat.com/1528859

 .../inventory_collection_default/infra_manager.rb  | 36 ++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comment 17 CFME Bot 2018-01-08 13:39:02 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/2ede836323c8d0fbe48fe1648bda0f14b2314101

commit 2ede836323c8d0fbe48fe1648bda0f14b2314101
Author:     Piotr Kliczewski <piotr.kliczewski@gmail.com>
AuthorDate: Fri Jan 5 16:06:32 2018 +0100
Commit:     Piotr Kliczewski <piotr.kliczewski@gmail.com>
CommitDate: Mon Jan 8 11:54:59 2018 +0100

    Reconnect host on provider add
    
    We need to make sure that when we remove a provider and add it again we
    will keep using the same host entities. Without this change add and remove
    provider cause to duplicate hosts.
    
    Fixes https://bugzilla.redhat.com/1528859

 .../inventory_collection_default/infra_manager.rb  | 36 ++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comment 19 CFME Bot 2018-01-09 14:30:55 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/efaa339af78a230eed513d002ce4487ae162a977

commit efaa339af78a230eed513d002ce4487ae162a977
Author:     Piotr Kliczewski <piotr.kliczewski@gmail.com>
AuthorDate: Mon Jan 8 17:19:39 2018 +0100
Commit:     Piotr Kliczewski <piotr.kliczewski@gmail.com>
CommitDate: Mon Jan 8 17:22:18 2018 +0100

    Reconnect host on provider add
    
    Persister expect all the methods to define collection attributes when
    performin targeted refresh so moving the lambda.
    
    Fixes https://bugzilla.redhat.com/1528859

 .../inventory_collection_default/infra_manager.rb  | 67 ++++++++++++++--------
 1 file changed, 43 insertions(+), 24 deletions(-)

Comment 20 CFME Bot 2018-01-09 14:34:56 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/efaa339af78a230eed513d002ce4487ae162a977

commit efaa339af78a230eed513d002ce4487ae162a977
Author:     Piotr Kliczewski <piotr.kliczewski@gmail.com>
AuthorDate: Mon Jan 8 17:19:39 2018 +0100
Commit:     Piotr Kliczewski <piotr.kliczewski@gmail.com>
CommitDate: Mon Jan 8 17:22:18 2018 +0100

    Reconnect host on provider add
    
    Persister expect all the methods to define collection attributes when
    performin targeted refresh so moving the lambda.
    
    Fixes https://bugzilla.redhat.com/1528859

 .../inventory_collection_default/infra_manager.rb  | 67 ++++++++++++++--------
 1 file changed, 43 insertions(+), 24 deletions(-)

Comment 21 CFME Bot 2018-01-10 08:33:56 UTC
New commit detected on ManageIQ/manageiq-providers-ovirt/master:
https://github.com/ManageIQ/manageiq-providers-ovirt/commit/90fcaed2de4fa587e256f892bf5a66ecaf23676f

commit 90fcaed2de4fa587e256f892bf5a66ecaf23676f
Author:     Piotr Kliczewski <piotr.kliczewski@gmail.com>
AuthorDate: Fri Jan 5 14:01:03 2018 +0100
Commit:     Piotr Kliczewski <piotr.kliczewski@gmail.com>
CommitDate: Tue Jan 9 15:56:21 2018 +0100

    Reconnect host on provider add
    
    We need to make sure that when we remove a provider and add it again we
    will keep using the same host entities. Without this change add and remove
    provider cause to duplicate hosts.
    
    Fixes https://bugzilla.redhat.com/1528859

 .../refresh/refresher_4_async_graph_spec.rb        | 36 ++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comment 22 Ilanit Stein 2018-01-11 09:26:37 UTC
(In reply to Piotr Kliczewski from comment #14)
> Ilanit, I noticed that host status is the same for both refresh types. I
> suggest to open new BZ to cover only status.

Filed this bug (which is unrelated to the refresh type)
Bug 1533397 - Archived Hosts have power State "On" in the Host summary page

Comment 23 Ilanit Stein 2018-09-17 10:51:07 UTC
Verified on CFME-5.10.0.15 (That has Graph refresh ON, by default)/RHV-4.2.3.

Remove RHV provider makes hosts turn into Archived, and when the RHV is added back,
same host tun into Active.


Note You need to log in before you can comment on or make changes to this bug.