Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 152882 - File system corruption running kernel 2.4.20-37.7.legacy (SMP)
Summary: File system corruption running kernel 2.4.20-37.7.legacy (SMP)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Legacy
Classification: Retired
Component: General
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Fedora Legacy Bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-12 10:21 UTC by Steve Knodle
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description David Lawrence 2005-03-30 23:30:51 UTC
File system corruption after running kernel 2.4.20-37.7.legacy (SMP) 
on a dual processor IBM x345.  Several files became "invisible" unless
the system is booted in rescue mode from the install CD. "e2fsck -f" reports
no problems when run either from rescue mode or multiuser mode on new lernel.
One of these files is "/usr/bin/yum".  From rescue mode, I can   tar these
files, untar them to another file system, and the files are visible normally.

Attempts to create a file (as root) named "/usr/bin/yum" while running kernel
2.4.20-37.7.legacy (SMP) returns the error "permission denied".

This indicates two problems:
1. possible race condition in SMP file system code (hard to find)
2. insufficient consistency checks in "e2fsck" that do not detect this
   error condition. (much easier to find)

As soon as time permits, I will run "fsdebug" against this file system,
and examine binary dumps of the directories involved in an attempt to determine
what inconsistency is not being caught by e2fsck.



------- Additional Comments From slk@bu.edu 2005-01-12 12:32:43 ----

AGGGHHHHH!  NOT A BUG.

Some idiot had configured this machine to NFS-mount "/usr/bin" off another!!!!
When I helped with the upgrade, things worked fine until the last stages of the 
upgrade!!!

Sorry to bother you..



------- Bug moved to this database by dkl@redhat.com 2005-03-30 18:30 -------

This bug previously known as bug 2376 at https://bugzilla.fedora.us/
https://bugzilla.fedora.us/show_bug.cgi?id=2376
Originally filed under the Fedora Legacy product and General component.

Unknown priority P2. Setting to default priority "normal".
Unknown platform PC. Setting to default platform "All".
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.




Note You need to log in before you can comment on or make changes to this bug.