Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 152823 - up2date fails on legacy FC1
Summary: up2date fails on legacy FC1
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora Legacy
Classification: Retired
Component: up2date
Version: fc1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Fedora Legacy Bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-23 04:13 UTC by Nigel Horne
Modified: 2007-04-18 17:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-23 22:36:51 UTC


Attachments (Terms of Use)

Description David Lawrence 2005-03-30 23:28:42 UTC
running rhn-applet-gui gives these cryptic errors:

Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1358, in onChannelsPageNext
    self.pList.run()
  File "/usr/share/rhn/up2date_client/packageList.py", line 117, in run
    self.progressCallback)
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 315, in
getAvailableAllArchPackageList
    package_list = availablePackageList(
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 153, in
availablePackageList
    progressCallback = progressCallback)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 112, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 20, in listPackages
    return self.handlers[channel['type']].listPackages(channel, msgCallback,
progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 226, in listPackages
    msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line 267, in
listPackages
    hdr = rd.getHeader([name,ver,rel,epoch,arch, "0",channel['label']])
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 31, in getHeader
    return self.handlers[channel['type']].getHeader(pkg, msgCallback,
progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 210, in getHeader
    header = source.getHeader(pkg, progressCallback = progressCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line 96, in
getHeader
    hdrBuf = fh.read()
  File "/usr/lib/python2.2/gzip.py", line 156, in read
    self._read(readsize)
  File "/usr/lib/python2.2/gzip.py", line 198, in _read
    self._read_gzip_header()
  File "/usr/lib/python2.2/gzip.py", line 110, in _read_gzip_header
    raise IOError, 'Not a gzipped file'
IOError: Not a gzipped file
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1424, in onSkippedPagePrepare
    self.__preparePackageList()
  File "/usr/share/rhn/up2date_client/gui.py", line 1310, in __preparePackageList
    self.pList.run()
  File "/usr/share/rhn/up2date_client/packageList.py", line 117, in run
    self.progressCallback)
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 315, in
getAvailableAllArchPackageList
    package_list = availablePackageList(
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 153, in
availablePackageList
    progressCallback = progressCallback)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 112, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 20, in listPackages
    return self.handlers[channel['type']].listPackages(channel, msgCallback,
progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 226, in listPackages
    msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line 267, in
listPackages
    hdr = rd.getHeader([name,ver,rel,epoch,arch, "0",channel['label']])
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 31, in getHeader
    return self.handlers[channel['type']].getHeader(pkg, msgCallback,
progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 210, in getHeader
    header = source.getHeader(pkg, progressCallback = progressCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line 96, in
getHeader
    hdrBuf = fh.read()
  File "/usr/lib/python2.2/gzip.py", line 156, in read
    self._read(readsize)
  File "/usr/lib/python2.2/gzip.py", line 198, in _read
    self._read_gzip_header()
  File "/usr/lib/python2.2/gzip.py", line 110, in _read_gzip_header
    raise IOError, 'Not a gzipped file'
IOError: Not a gzipped file



------- Bug moved to this database by dkl@redhat.com 2005-03-30 18:28 -------

This bug previously known as bug 2193 at https://bugzilla.fedora.us/
https://bugzilla.fedora.us/show_bug.cgi?id=2193
Originally filed under the Fedora Legacy product and General component.

Unknown priority P3. Setting to default priority "normal".
Unknown platform PC. Setting to default platform "All".
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.



Comment 1 Dominic Hargreaves 2005-04-06 13:08:06 UTC
Can you reproduce this reliably? Does the same thing happen if you invoke
up2date without using the gui? (Is it even still happening?)

Thanks,

Comment 2 Nigel Horne 2005-04-06 13:13:26 UTC
This is v. old and I now run FC3.  
 
FC3 gives this warning, but no error that I can see: 
 
/usr/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.py:90: 
GtkDeprecationWarning: gtk.mainloop is deprecated, use gtk.main instead 
  self.warn(message, DeprecationWarning) 
 

Comment 3 Matthew Miller 2005-04-12 17:52:25 UTC
Can anyone reproduce this? Not sure that this is a general issue rather than
just a specific one-time problem maybe with a bad repository.

Comment 4 Todd Warner 2005-09-23 22:36:51 UTC
a year old and really a non-issue now I presume. reopen or file a new bug if it
pops it's ugly head again.


Note You need to log in before you can comment on or make changes to this bug.