Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 152559 - makedepend searches the wrong directories for compiler includes
Summary: makedepend searches the wrong directories for compiler includes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 3
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
: 165922 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-03-30 12:22 UTC by Mattias Ellert
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-24 23:59:49 UTC


Attachments (Terms of Use)

Description Mattias Ellert 2005-03-30 12:22:10 UTC
Description of problem:

After updating to xorg-x11-devel-6.8.2-1.FC3.13 makedepend does not work any
more. It looks for compiler includes in the wrong directory...

Version-Release number of selected component (if applicable):

[ellert@ellert tmp]$ which makedepend
/usr/X11R6/bin/makedepend
[ellert@ellert tmp]$ rpm -q --whatprovides /usr/X11R6/bin/makedepend
xorg-x11-devel-6.8.2-1.FC3.13
[ellert@ellert tmp]$ strings /usr/X11R6/bin/makedepend | grep 3.4
/usr/lib/gcc/i386-redhat-linux/3.4.3/include

But the gcc version on FC3 is 3.4.2:

[ellert@ellert tmp]$ gcc --version
gcc (GCC) 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)
Copyright (C) 2004 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


How reproducible:

Always

Steps to Reproduce:
1. run makedepend on a file that includes a compiler include file like e.g.:

[ellert@ellert tmp]$ cat test.c
#include <stddef.h>
int main() {}

[ellert@ellert tmp]$ makedepend test.c
makedepend: warning:  test.c, line 1: cannot find include file "stddef.h"
        not in /usr/local/lib/gcc-include/stddef.h
        not in /usr/include/stddef.h
        not in /usr/lib/gcc/i386-redhat-linux/3.4.3/include/stddef.h


Actual results: Error message above

Expected results: No error

Additional info:

On a differnt machine where xorg-x11 hasn't been updated yet it works:

[sysadmin@swelanka1 tmp]$ strings /usr/X11R6/bin/makedepend | grep 3.4
/usr/lib/gcc/i386-redhat-linux/3.4.2/include
[sysadmin@swelanka1 tmp]$ rpm -q xorg-x11-devel
xorg-x11-devel-6.8.1-12.FC3.21
[sysadmin@swelanka1 tmp]$ makedepend test.c
[sysadmin@swelanka1 tmp]$

Comment 1 Mike A. Harris 2005-04-11 11:21:16 UTC
You can use "gccmakedep" instead of "makedepend".  At one point we had
makedepend as a symlink to gccmakedep if I'm not mistaken.  It seems
that changed somewhere along the line, and we should consider adding it
back.

You may wish to report this bug to X.Org as well, so it gets fixed
in the upstream X.org sources.



Comment 2 Mike A. Harris 2005-08-30 06:59:04 UTC
*** Bug 165922 has been marked as a duplicate of this bug. ***

Comment 3 Mike A. Harris 2005-08-30 07:10:38 UTC
This problem appears to be a generic bug with the upstream X.Org makedepend,
rather than a Fedora Core specific bug.  Please file a bug report in the
X.Org bugzilla for this issue at:  http://bugs.freedesktop.org in the
"xorg" component.

Once you have filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.


Comment 4 Mike A. Harris 2005-08-30 07:11:25 UTC
Setting status to "NEEDINFO_REPORTER" and awaiting upstream bug URL
for tracking.

Comment 5 Mike A. Harris 2005-09-24 23:59:49 UTC
The problem should be fixed in the latest update for Fedora Core 4.  If
the problem returns in the future, please follow the instructions in
comment #3 above for a permanent solution.

Setting status to "ERRATA"


Note You need to log in before you can comment on or make changes to this bug.