Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1525259 - [UPDATES] zaqar - socket is already closed [NEEDINFO]
Summary: [UPDATES] zaqar - socket is already closed
Keywords:
Status: CLOSED DUPLICATE of bug 1517262
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: mathieu bultel
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-12 22:20 UTC by Yurii Prokulevych
Modified: 2018-02-01 14:54 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-01 14:54:53 UTC
Target Upstream Version:
pkilambi: needinfo? (mbultel)


Attachments (Terms of Use)

Description Yurii Prokulevych 2017-12-12 22:20:01 UTC
Description of problem:
-----------------------
Running minor update on all oc nodes got interrupted:

openstack overcloud update stack 2>&1
...
 u'    "failed_when_result": false',
 u'}',
 u'',
 u'TASK [Check if /var/lib/docker-puppet/docker-puppet-tasks5.json exists] ********',
 u'ok: [192.168.24.21]',
 u'',
 u'TASK [Run docker-puppet tasks (bootstrap tasks)] *******************************',
 u'skipping: [192.168.24.21]',
 u'',
 u'TASK [debug] *******************************************************************',
 u'skipping: [192.168.24.21]',
 u'',
 u'PLAY RECAP *********************************************************************',
 u'192.168.24.10              : ok=58   changed=13   unreachable=0    failed=0   ',
 u'192.168.24.12              : ok=56   changed=13   unreachable=0    failed=0   ',
 u'192.168.24.14              : ok=58   changed=13   unreachable=0    failed=0   ',
 u'192.168.24.16              : ok=56   changed=13   unreachable=0    failed=0   ',
 u'192.168.24.17              : ok=56   changed=13   unreachable=0    failed=0   ',
 u'192.168.24.19              : ok=112  changed=56   unreachable=0    failed=0   ',
 u'192.168.24.21              : ok=112  changed=56   unreachable=0    failed=0   ',
 u'192.168.24.7             Waiting for messages on queue 'ed6424d9-0559-4af7-aef9-1c2a60e8bbd5' with no timeout.
socket is already closed.
  : ok=114  changed=56   unreachable=0    failed=0   ',
 u'']
('Response is not a JSON object.', ValueError('No JSON object could be decoded',))
(undercloud) [stack@undercloud-0 ~ (undercloud-12-TLV11)]$ 

And in zaqar-server.log
=======================
2017-12-12 14:41:04.725 1385 INFO swiftclient [-] RESP BODY: <html><h1>Not Found</h1><p>The resource could not be found.</p></html>
2017-12-12 14:41:04.777 1385 INFO zaqar.transport.websocket.protocol [-] Response: API v2 txt, 201. Request: action "subscription_create", body {"queue_name": "ed6424d9-0559-4af7-aef9-1c2a60e8bbd5", "ttl": 10000}.
2017-12-12 15:41:05.056 1385 INFO zaqar.transport.websocket.protocol [-] WebSocket connection closed: connection was closed uncleanly (peer dropped the TCP connection without previous WebSocket closing handshake)


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
python-zaqarclient-1.7.0-1.el7ost.noarch
openstack-zaqar-5.0.0-3.el7ost.noarch
puppet-zaqar-11.3.0-3.el7ost.noarch
openstack-tripleo-common-7.6.3-8.el7ost.noarch
openstack-tripleo-common-containers-7.6.3-8.el7ost.noarch
openstack-tripleo-heat-templates-7.0.3-18.el7ost.noarch


Steps to Reproduce:
-------------------
1. Update UC
2. Install latest repos on oc nodes and prepare docker images
3. Run init-minor-update to configure heat's output
4. Run update command:
    openstack overcloud update stack 2>&1

Comment 2 mathieu bultel 2017-12-13 15:01:44 UTC
This issue is related (and probably duplicated) from:
https://bugzilla.redhat.com/show_bug.cgi?id=1517262

Comment 5 Pradeep Kilambi 2018-01-04 14:35:59 UTC
If this is a duplicate of bug#1517262 can we go ahead and close this?

Comment 6 Pradeep Kilambi 2018-02-01 14:54:53 UTC

*** This bug has been marked as a duplicate of bug 1517262 ***


Note You need to log in before you can comment on or make changes to this bug.