Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1525059 - No event in timeline for the web console activity in RHV41
Summary: No event in timeline for the web console activity in RHV41
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.9.0
Assignee: Piotr Kliczewski
QA Contact: Ilanit Stein
URL:
Whiteboard:
Depends On: 1518330 1544460
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-12 14:40 UTC by Satoe Imaishi
Modified: 2018-03-06 15:17 UTC (History)
14 users (show)

Fixed In Version: 5.9.0.13
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1518330
Environment:
Last Closed: 2018-03-06 15:17:17 UTC
Category: ---
Cloudforms Team: RHEVM
istein: needinfo-
istein: needinfo+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ManageIQ manageiq-providers-ovirt pull 173 None None None 2017-12-12 14:41:11 UTC

Comment 2 CFME Bot 2017-12-12 14:50:24 UTC
New commit detected on ManageIQ/manageiq-providers-ovirt/gaprindashvili:
https://github.com/ManageIQ/manageiq-providers-ovirt/commit/8ad7a60e5371da7c96e62b98942a34e1ed6a4ffb

commit 8ad7a60e5371da7c96e62b98942a34e1ed6a4ffb
Author:     Oved Ourfali <oourfali@redhat.com>
AuthorDate: Tue Dec 12 12:10:00 2017 +0200
Commit:     Satoe Imaishi <simaishi@redhat.com>
CommitDate: Tue Dec 12 09:41:14 2017 -0500

    Merge pull request #173 from pkliczewski/master
    
    Handle console events
    (cherry picked from commit 69aed1fbd8ee3e7a9c9e89cb1c79aa2066b4ed64)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1525059

 app/models/manageiq/providers/redhat/infra_manager/event_fetcher.rb | 4 ++++
 config/settings.yml                                                 | 6 ++++++
 2 files changed, 10 insertions(+)

Comment 3 Ilanit Stein 2018-01-17 12:22:45 UTC
Tested on CFME-5.8.3.1/RHV-4.1.8.

No Console events were displayed under Timelines.
No UNKNOWN events mentioned in evm.log.

When moving CFME to api version 4 - The Console events were displayed under the timelines.

Piotr,
Is this the expected behavior please?

Thanks.

Comment 4 Ilanit Stein 2018-01-17 14:00:57 UTC
Comment 3 was mistakenly put here, and was suppose to be added to the 5.8.3 cloned bug 1525583

Comment 5 Ilanit Stein 2018-01-17 14:30:08 UTC
Tested on CFME-5.9.0.16/RHV-4.1.8:

The only Console events displayed under Timelines->Console Activity are only VM_SET_TICKET events.

Console events: 
1. VM_CONSOLE_CONNECTED
2. VM_CONSOLE_DISCONNECTED 
are not displayed.

Note that on CFME-5.8.3.1 (with api version 4), all the above console events are displayed.

Piotr,

Would you please check?

Thanks.

Comment 6 Piotr Kliczewski 2018-01-17 17:46:01 UTC
Sure, will verify it.

Comment 7 Ilanit Stein 2018-02-13 13:17:47 UTC
After investigation with boriso it turned out that 
Console events: 
1. VM_CONSOLE_CONNECTED
2. VM_CONSOLE_DISCONNECTED 
are not displayed, because of Bug 1544460 - "TypeError: no implicit conversion of Symbol into Integer on appending EmsEvent"

In evm.log, after those 2 events are caught, such error is seen.

When adding CFME the fix for bug 1544460, those 2 events are displayed under timelines.

Note that on CFME-5.8.3.1 bug 1544460 do not exist, and thus it worked there.

We noticed additional problem: if the VM console is opened, and immediately closed,
even if the bug 1544460 is added, VM_CONSOLE_CONNECTED, VM_CONSOLE_DISCONNECTED are not displayed under Timelines

* All above testing were by open VM console from CFME side.   

This bug can be verified once 1544460 move to ON_QA.

Comment 8 Ilanit Stein 2018-02-15 07:40:37 UTC
Verified on CFME-5.9.0.21/RHV-4.1.8.2

All events are now displayed under VM Timelines:

1. VM_SET_TICKET
2. VM_CONSOLE_CONNECTED
3. VM_CONSOLE_DISCONNECTED 

ERROR: 
"[TypeError]: no implicit conversion of Symbol into Integer  Method:[block in method_missing]", 
That existed for CFME-5.9.0.20, in evm.log, no longer exist in CFME-5.9.0.21.


Note You need to log in before you can comment on or make changes to this bug.