Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1524933 - Adding new role, group or user not happened after single click on add button
Summary: Adding new role, group or user not happened after single click on add button
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Zita Nemeckova
QA Contact: Pavol Kotvan
URL:
Whiteboard: ui
: 1512359 1524858 1525093 1525126 1527382 1527388 1529079 (view as bug list)
Depends On:
Blocks: 1526074
TreeView+ depends on / blocked
 
Reported: 2017-12-12 10:24 UTC by nzayats
Modified: 2018-06-21 20:57 UTC (History)
12 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1526074 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:57:49 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description nzayats 2017-12-12 10:24:34 UTC
Description of problem:
Adding new role, group or user not happened after single click on add button.
After double click we receive error (see below), but role/group/user is created.

"Edit aborted! CFME does not support the browser's back button or access from multiple tabs or windows of the same browser. Please close any duplicate sessions before proceeding."

Version-Release number of selected component (if applicable):
5.9.0.12

How reproducible:
100%

Steps to Reproduce:
1.Create new role, group or user
2.Fill all required fields
3.Click on Add button
4.Double click on Add button

Actual results:
After single click on Add button (step 3) we are still on the creation page.
After next click on Add button (step 4) we are redirected to page with a list of all roles, groups, users and receive the message (see below) but role/group/user is created.

"Edit aborted! CFME does not support the browser's back button or access from multiple tabs or windows of the same browser. Please close any duplicate sessions before proceeding."

Expected results:
After single click on add button, we receive message 'Role/Group/User "name" was saved' and role/group/user is successfully created.

Additional info:

Comment 6 lgalis 2017-12-13 14:00:24 UTC
*** Bug 1525093 has been marked as a duplicate of this bug. ***

Comment 7 lgalis 2017-12-13 14:01:14 UTC
*** Bug 1524858 has been marked as a duplicate of this bug. ***

Comment 8 Zita Nemeckova 2017-12-13 15:01:30 UTC
*** Bug 1525126 has been marked as a duplicate of this bug. ***

Comment 10 Dávid Halász 2017-12-20 17:31:57 UTC
*** Bug 1527382 has been marked as a duplicate of this bug. ***

Comment 11 Dávid Halász 2017-12-20 17:34:21 UTC
*** Bug 1512359 has been marked as a duplicate of this bug. ***

Comment 12 Dávid Halász 2017-12-20 17:57:47 UTC
*** Bug 1527388 has been marked as a duplicate of this bug. ***

Comment 13 Aziza Karol 2018-01-05 04:37:15 UTC
*** Bug 1529079 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.