Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1524415 - Smart State Analysis doesn't update "Patches" and "Applications" for Windows server 2016.
Summary: Smart State Analysis doesn't update "Patches" and "Applications" for Windows ...
Keywords:
Status: CLOSED DUPLICATE of bug 1508281
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: 5.7.4
Assignee: Jerry Keselman
QA Contact: Satyajit Bulage
URL:
Whiteboard: smartstate:vmware:vm
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-11 12:54 UTC by Satyajit Bulage
Modified: 2017-12-12 17:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-12 16:04:43 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
evm.log during SSA on VM (deleted)
2017-12-11 12:54 UTC, Satyajit Bulage
no flags Details

Description Satyajit Bulage 2017-12-11 12:54:56 UTC
Created attachment 1365983 [details]
evm.log during SSA on VM

Description of problem: SSA retrieves all data except Patches information and throws error "undefined method `split' for nil:NilClass" in evm.log


Version-Release number of selected component (if applicable):5.7.4.2.20171207173836_e563ef4


How reproducible:100%


Steps to Reproduce:
1. Perform SSA on Windows Server 2016.
2.
3.

Actual results: SSA is not retrieving "Patches" and "Applications" information and throwing error in evm.log


Expected results: SSA should succeed without any error.


Additional info:

Comment 2 Dave Johnson 2017-12-11 15:07:45 UTC
Satyajit, is this a regression, was it working in 5.7.3?  Did you see it working in 5.7.4.1?

Comment 4 Jerry Keselman 2017-12-11 22:42:33 UTC
This is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1490488 opened by Satyajit several months ago.

*** This bug has been marked as a duplicate of bug 1490488 ***

Comment 7 Jerry Keselman 2017-12-12 14:24:10 UTC
You are correct Satyajit.  Reopening - I *think* we fixed an issue with this message - I'll look for it and update appropriately if I am correct.

Comment 8 Jerry Keselman 2017-12-12 16:04:43 UTC
Looking at the attached log file I realized that this is actually a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1508281, for which a fix has been supplied.  Closing as a duplicate again.

*** This bug has been marked as a duplicate of bug 1508281 ***

Comment 10 Jerry Keselman 2017-12-12 17:11:19 UTC
Satyajit this fix has nothing to do with what version of Windows this is.


Note You need to log in before you can comment on or make changes to this bug.