Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1524372 - Cockpit hosted-engine plugin asks the engine FQDN twice.
Summary: Cockpit hosted-engine plugin asks the engine FQDN twice.
Keywords:
Status: CLOSED DUPLICATE of bug 1516121
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Hosted Engine
Version: 0.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Phillip Bailey
QA Contact: dguo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-11 11:13 UTC by Simone Tiraboschi
Modified: 2017-12-11 11:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-11 11:37:06 UTC
oVirt Team: SLA


Attachments (Terms of Use)
FQDN 1 (deleted)
2017-12-11 11:15 UTC, Simone Tiraboschi
no flags Details
FQDN 5 (deleted)
2017-12-11 11:15 UTC, Simone Tiraboschi
no flags Details

Description Simone Tiraboschi 2017-12-11 11:13:00 UTC
Description of problem:
cockpit hosted-engine plugin asks the engine FQDN twice (see attached screenshots), one in section 1 and one in section 5 (probably over OTOPI machine dialog).

This is probably due to the fact that the cockpit plugin uses the wrong key in its answer file.
The right key is OVEHOSTED_VM/cloudinitInstanceHostName


Version-Release number of selected component (if applicable):
4.2 RC1

How reproducible:
100%

Steps to Reproduce:
1. deploy hosted-engine from cockpit
2.
3.

Actual results:
it asks the engine FQDN twice

Expected results:
it asks the engine FQDN only once

Additional info:

Comment 1 Simone Tiraboschi 2017-12-11 11:15:09 UTC
Created attachment 1365933 [details]
FQDN 1

Comment 2 Simone Tiraboschi 2017-12-11 11:15:36 UTC
Created attachment 1365934 [details]
FQDN 5

Comment 3 Phillip Bailey 2017-12-11 11:37:06 UTC
This issue has been addressed in [1] reported previously in [2].

[1] https://gerrit.ovirt.org/#/c/85166/
[2] https://bugzilla.redhat.com/show_bug.cgi?id=1516121

*** This bug has been marked as a duplicate of bug 1516121 ***


Note You need to log in before you can comment on or make changes to this bug.