Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1524148 - Hosted Engine Deployment wizard in cockpit asking the same questions twice
Summary: Hosted Engine Deployment wizard in cockpit asking the same questions twice
Keywords:
Status: CLOSED DUPLICATE of bug 1516121
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Hosted Engine
Version: ---
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Phillip Bailey
QA Contact: dguo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-10 11:50 UTC by Michael Burman
Modified: 2017-12-11 02:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-11 02:07:47 UTC
oVirt Team: Integration


Attachments (Terms of Use)
screenshots (deleted)
2017-12-10 12:06 UTC, Michael Burman
no flags Details

Description Michael Burman 2017-12-10 11:50:06 UTC
Description of problem:
Hosted Engine Deployment wizard in cockpit asking the same questions twice

Now in cockpit we have a new wizard installation for the hosted engine, it is nice, but it asking the user/admin the same configuration question twice.
- In the beginning you are asked to enter all relevant storage, VM and engine info, but then after approving anything and starting to deploy, we are asked again for the same questions, which we already answered in steps 1-5 in the wizard.
The second round of the question appears to be a part of the old HE installation wizard. 

We should be asked only once before and during the deploy.

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-ha-2.2.0-0.2.master.gitcbe3c76.el7ev.noarch
ovirt-hosted-engine-setup-2.2.0-0.4.master.git0b67c21.el7ev.noarch

cockpit-151-1.el7.x86_64
cockpit-ovirt-dashboard-0.11.1-0.4.el7ev.noarch
cockpit-bridge-151-1.el7.x86_64
cockpit-ws-151-1.el7.x86_64
cockpit-dashboard-151-1.el7.x86_64
cockpit-system-151-1.el7.noarch
cockpit-storaged-151-1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Start hosted-engine deploy via cockpit

Actual results:
Asked twice for the same configuration question in the new HE wizard installation

Expected results:
Should be asked only once

Comment 1 Michael Burman 2017-12-10 12:06:06 UTC
Created attachment 1365575 [details]
screenshots

Comment 2 Phillip Bailey 2017-12-11 02:07:47 UTC

*** This bug has been marked as a duplicate of bug 1516121 ***


Note You need to log in before you can comment on or make changes to this bug.