Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1522745 - sysadm users cannot execute 'puppet agent' command
Summary: sysadm users cannot execute 'puppet agent' command
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.5
Hardware: All
OS: Linux
urgent
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On: 1515499
Blocks: 1374441
TreeView+ depends on / blocked
 
Reported: 2017-12-06 11:16 UTC by Lukas Vrabec
Modified: 2018-04-10 12:48 UTC (History)
11 users (show)

Fixed In Version: selinux-policy-3.13.1-182.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1515499
Environment:
Last Closed: 2018-04-10 12:47:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0763 None None None 2018-04-10 12:48:22 UTC

Comment 5 Milos Malik 2018-01-31 06:31:41 UTC
The reproducer needs the puppetmaster service to be running, otherwise it prints a lot of "Connection refused" messages. Unfortunately, the puppetmaster service is not able to run because of BZ#1376893. I believe that BZ#1376893 needs to be fixed as well.

Comment 6 Milos Malik 2018-01-31 06:37:04 UTC
Tested with 2 different versions of puppet* packages:

EPEL
====
puppet-3.6.2-3.el7.noarch
puppet-server-3.6.2-3.el7.noarch

Brew
====
puppet-server-4.8.2-2.el7ost.noarch
puppet-4.8.2-2.el7ost.noarch

None of them was successful.

Comment 12 errata-xmlrpc 2018-04-10 12:47:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0763


Note You need to log in before you can comment on or make changes to this bug.