Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 152262 - rpmbuild searches %doc for perl reqs
Summary: rpmbuild searches %doc for perl reqs
Keywords:
Status: CLOSED DUPLICATE of bug 173087
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-03-26 23:32 UTC by Chris Petersen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-14 03:11:45 UTC


Attachments (Terms of Use)
test casee (deleted)
2005-05-19 21:40 UTC, Paul Nasrat
no flags Details

Description Chris Petersen 2005-03-26 23:32:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Galeon/1.3.20

Description of problem:
AFAIK, rpmbuild is not supposed to search %doc files/directories for perl requirements.  For lack of a better place to put it, I'm including some "contrib" stuff in the %doc for a spec I'm building (mythtv), and it happens to have some perl scripts in it.

Temporary fix is to `chmod a-x` on all files in contrib, but I don't think that rpm should be matching those for the package requirements in the first place.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
see description

Additional info:

Comment 1 Jeff Johnson 2005-04-01 20:24:12 UTC
Yes, chmod -x on perl scripts included in %doc will disable dependency extraction.

One questions whether %doc is useful or adequate means to distribute
scripts.

Comment 2 Chris Petersen 2005-04-01 20:40:39 UTC
where else would you put "contrib" scripts?  They're not part of the official
package or even necessarily endorsed by the authors, but leaving them out means
that users then have to track down the source if they ever want to see what's there.

It'd be nice to be able to keep them executable, but completely unrelated to
this, why is rpm even searching %doc stuff for execution dependencies?

Comment 3 Paul Nasrat 2005-05-19 21:40:43 UTC
Created attachment 114596 [details]
test casee

Simple test package

...
Requires: /usr/bin/perl perl(Win32::Foo)
...

Comment 4 Paul Nasrat 2005-05-19 22:18:46 UTC
Requires finding occurs with rpms file classifcation process which occurs on all
files.  This is agnostic of file flags (config, doc).  Changing this for FC4 is
probalby way too late.

You can work around by setting %attr in %files so once installed they are
executable but not inspected during the requires finding.

You can confirm this by changing the chmod line to:

chmod 644 %{name}.pl

[pauln@enki SPECS]$ rpm -qpR ../RPMS/perljam-1.0-1.noarch.rpm
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

Move to FC5 target.





Comment 5 Jeff Johnson 2005-11-14 03:11:45 UTC

*** This bug has been marked as a duplicate of 173087 ***


Note You need to log in before you can comment on or make changes to this bug.