Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1520469 - Selecting a VPN in NetworkManager won't prompt for a password when no there're no saved password
Summary: Selecting a VPN in NetworkManager won't prompt for a password when no there'r...
Keywords:
Status: CLOSED DUPLICATE of bug 1519527
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager-openvpn
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-04 14:29 UTC by David Hill
Modified: 2017-12-04 14:34 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-04 14:34:37 UTC


Attachments (Terms of Use)

Description David Hill 2017-12-04 14:29:29 UTC
Description of problem:
When selecting a VPN that has no password , nothing happens .   This was working fine before but since the last update, I'm no longer prompted for a password when trying to connect to openvpn 

Version-Release number of selected component (if applicable):
Started with this update:
dnf.log-20171203:  NetworkManager-libreswan.x86_64 1.2.4-5.fc28                                                           
dnf.log-20171203:  NetworkManager-libreswan-gnome.x86_64 1.2.4-5.fc28                                                     
dnf.log-20171203:  NetworkManager-openconnect.x86_64 1.2.4-7.fc28                                                         
dnf.log-20171203:  NetworkManager-openvpn.x86_64 1:1.8.0-4.fc28                                                           
dnf.log-20171203:  NetworkManager-openvpn-gnome.x86_64 1:1.8.0-4.fc28                                                     
dnf.log-20171203:  NetworkManager-pptp.x86_64 1:1.2.4-5.fc28                                                              
dnf.log-20171203:  NetworkManager-pptp-gnome.x86_64 1:1.2.4-5.fc28                                                        
dnf.log-20171203:  NetworkManager-vpnc.x86_64 1:1.2.4-5.fc28                                                              
dnf.log-20171203:  NetworkManager-vpnc-gnome.x86_64 1:1.2.4-5.fc28                                                        
dnf.log-20171203:  dracut-network.x86_64 046-36.git20171201.fc28          

How reproducible:
Don't know

Steps to Reproduce:
1. Update
2. Reboot
3. Try connecting to an openvpn 

Actual results:
No password prompts

Expected results:
Password prompt 

Additional info:

Comment 1 Thomas Haller 2017-12-04 14:34:37 UTC

*** This bug has been marked as a duplicate of bug 1519527 ***


Note You need to log in before you can comment on or make changes to this bug.