Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1520000 - Calibre won't install anymore or blocks upgrade of qt library
Summary: Calibre won't install anymore or blocks upgrade of qt library
Keywords:
Status: CLOSED DUPLICATE of bug 1516755
Alias: None
Product: Fedora
Classification: Fedora
Component: calibre
Version: 26
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-01 21:36 UTC by Alwin
Modified: 2017-12-02 10:33 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-02 10:33:53 UTC


Attachments (Terms of Use)

Description Alwin 2017-12-01 21:36:47 UTC
Description of problem:

Calibre blocked the update of qt library to 5.9.x. After uninstalling calibre, qt upgrade worked. But reinstall isn't possible 'cause wrong dependency of calibre. 

Version-Release number of selected component (if applicable):

calibre-3.11.1-1.fc26.x86_64

How reproducible:


Steps to Reproduce:
1. Try update fedora 26 with installed calibre
2. or remove calibre, update and then try reinstall of calibre.


Actual results:

  - package calibre-3.11.1-1.fc26.x86_64 requires qt5-qtbase(x86-64) = 5.7.1, but none of the providers can be installed
  - package calibre-3.0.0-2.fc26.x86_64 requires qt5-qtbase(x86-64) = 5.7.1, but none of the providers can be installed
 - cannot install both qt5-qtbase-5.7.1-15.fc26.x86_64 and qt5-qtbase-5.9.2-5.fc26.x86_64


Expected results:


Calibre should not hard depend to qt5.7 but to qt5 or qt5.9 so it may upgraded.

Comment 1 Zbigniew Jędrzejewski-Szmek 2017-12-02 10:33:53 UTC

*** This bug has been marked as a duplicate of bug 1516755 ***


Note You need to log in before you can comment on or make changes to this bug.