Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519965 - anaconda experience after 25 or more uses for installing Fedora 22-27, gnome, kde, mate,
Summary: anaconda experience after 25 or more uses for installing Fedora 22-27, gnome,...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 27
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-01 19:36 UTC by Leslie Satenstein
Modified: 2018-05-09 00:30 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-09 00:30:34 UTC


Attachments (Terms of Use)

Description Leslie Satenstein 2017-12-01 19:36:56 UTC
Description of problem:

This is a request for cosmetic changes to Anaconda, after 3 years (6 releases) of use

Anaconda is my favourite installation program. Its not quite intuitive, but the design concept is great. Never-the-less, it has some quirks that need addressing. These quirks are mostly cosmetic. The following is my ideas for making anaconda more people friendly.

When Anaconda is launched...
=========================
On startup -- first screen

After confirming installation language, a disk scan takes place without any indication that it is happening. it could take many minutes before the scan of the disks on the user’s system completes. What is required is a courtesy message stating “Please wait, the disks are being scanned!

Justification… With 5 disks and multiple Linux installations on these 5 disks, scanning requires many minutes. I now wait 2 plus minutes for 5 disks, At one time I had to wait 7 minutes for the scan and analysis to complete.

Localisation Page (Map page).
=============================
The time zone is one hour off. From my IP address and the internal CPU clock, the correct zone could be determined. If I was in Vancouver or California, timewise, I would be located in the middle of the Pacific.




Installation Destination Screen
================================
The full disk summary, a clickable line at the very bottom of the screen, should be moved up and to the right of [Add a disk], When you install Fedora on more than one disk, and each disk has free space, that summary serves for defining which of the disks selected is to be the boot drive. It does not help with the configuration . If I choose disk A and disk B, Both A and B have free space, but Disk A has files that I want to access from the B-disk Linux I want to install. Anaconda will make the wrong choice. I have to not include disk A, but add disk A, post boot. Even with specifying boot from Drive B.

Another Issue.
-----------------
If your Linux config uses files on several disks, and you forget to select one of them after selecting the compusary four, you can’t add it without anaconda clearing out the selection and having you go through that setup a second time. If I do a setup on Disk A but then after that selection I want to add DiskB. Anaconda wipes out my previous selection. It should not, for reason mentioned above. Really frustrating. 



Manual Partitioning Screen
==========================

On entry, we have the line to create the partitioning automatically, and further beneath that line is the format selection for LVM, Standard, btrfs, etc. These two actions should be reversed. Let me first choose my partition and then how I want partitioning to be done.




Linux command line has a spurious message.
=========================================
Anaconda generates an warning error message at 1270. Something about size being zero.

Final Observation
================
5 disk system, DiskA has 150g free space, but for Disk B, almost zero free space, but I want to overwrite an existing Disk B Fedora installation.  Anaconda will not allow me to use custom setup as it defaults to use the disk with the most free space. 

Circumvention
=============
Do a single disk installation, After the reboot, modify the /etc/fstab and / to include the directories from the other disks.

Version-Release number of selected component (if applicable):

All versions of Anaconda

How reproducible:

Install Fedora onto a multi-disk system 

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

Hope that my feedback is useful.

Additional info:

Comment 1 Leslie Satenstein 2018-02-24 17:09:46 UTC
The window for determining the boot drive is not wide enough

I have 5 disks /sda through sdf because I have different Fedora versions (27 Gnome, 27 KDE, Rawhide Gnome, Rawhide KDE) and a non Fedora distribution distributed onto /dev/sda,/dev/sdb, /dev/sdd, /dev/sde. 

When the list of drives is presented, I click onto the drives that I need for my new installation (Targeting the kernel test onto /dev/sdc

/dev/sda  I want my /backup added to the fstab
/dev/sdd  I want my /scratch added to the fstab
/dev/sdb  I want my /spare  added to the fstab

/dev/sdc  where I am targeting an installation


The boot drive menu at the footing of the drive selection page is clicked to open the window.
Therein I see the drives I choose, that is, the a,b,c,d drives. Of course I want choose /dev/sdc.  But my drives are each WD's 1 TERRABYTE UNITS with very very similar names. I believe they are listed in the order I clicked on them.

The boot drive selection window truncates the information.  

I discovered by accident that I could select a line which lists one of the  drives in that window, and I could scroll that line to the right. 
At the right, the actual drive letter info "/sdc"  is presented.   
It is not immediately apparent that one clicks on the line and then on the command to make that drive the boot one.  
It is not apparent that the line can be scrolled, as there is no scroll bar at the footing of this popup window.

Please Fix


Note You need to log in before you can comment on or make changes to this bug.