Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519956 - Incorrect selector displayed during uninstall
Summary: Incorrect selector displayed during uninstall
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: cns-deploy-tool
Version: cns-3.6
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Michael Adam
QA Contact: Prasanth
URL:
Whiteboard:
Depends On:
Blocks: 1543779
TreeView+ depends on / blocked
 
Reported: 2017-12-01 19:03 UTC by Farid Saad
Modified: 2018-08-14 11:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 20:05:09 UTC


Attachments (Terms of Use)

Description Farid Saad 2017-12-01 19:03:08 UTC
Description of problem:
During uninstallation of Gluster using cns-deploy and specifying a custom selector for daemonset labels the default daemonset label is displayed

Version-Release number of selected component (if applicable):
5.0.0-54.el7rhgs.x86_64


How reproducible:

Steps to Reproduce:
1. Install using custom daemonset label selector:
cns-deploy -y -v -g -n gstorage02  --daemonset-label "glusterfsapp" --admin-key "admin" --user-key "user" --block-host "30" /tmp/topology.json 
2. Uninstall using same arguments
cns-deploy -y -v -g -n gstorage02  --daemonset-label "glusterfsapp" --admin-key "admin" --user-key "user" --block-host "30" /tmp/topology.json --abort

Actual results:
Output shows at bottom:
==
Removing glusterfs daemonset.
/usr/bin/oc -n gstorage02 delete ds --selector="glusterfs" 2>&1
==

Expected results:
==
Removing glusterfs daemonset.
/usr/bin/oc -n gstorage02 delete ds --selector="glusterfsapp" 2>&1
==

Additional info:
I think this is just displayed because the correct daemonset was removed.

Comment 5 Jose A. Rivera 2018-05-10 20:05:09 UTC
The "--daemonset-label <VALUE>" parameter specifies the value to use in the node selector of the daemonset. This labels the target nodes with the label "storagenode=<VALUE>". The selector being echoed in the script output is a selector against daemonsets (not nodes) for selecting daemonsets with a label "glusterfs" of any value. Thus, this is working as intended.


Note You need to log in before you can comment on or make changes to this bug.