Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519921 - [lua-devel] incorrect pkgconfig provides
Summary: [lua-devel] incorrect pkgconfig provides
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lua
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-01 17:18 UTC by Carl George
Modified: 2017-12-12 14:40 UTC (History)
6 users (show)

Fixed In Version: lua-5.3.4-7.fc27 lua-5.3.4-7.fc26 lua-5.3.4-7.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-12 11:22:51 UTC


Attachments (Terms of Use)

Description Carl George 2017-12-01 17:18:05 UTC
Description of problem:
lua-devel 5.3.4 contains /usr/lib64/pkgconfig/lua.pc that mistakenly lists the version as 5.3.0.  This results in an incorrect RPM provides as well.

# grep ^R= /usr/lib64/pkgconfig/lua.pc
R= 5.3.0
# rpm -q --provides lua-devel | grep pkg
pkgconfig(lua) = 5.3.0

Version-Release number of selected component (if applicable):
lua-devel-5.3.4-6.fc26.x86_64
lua-devel-5.3.4-6.fc27.x86_64
lua-devel-5.3.4-6.fc28.x86_64

Steps to Reproduce:
1. rpm -q --provides lua-devel | grep pkg

Actual results:
pkgconfig(lua) = 5.3.0

Expected results:
pkgconfig(lua) = 5.3.4

Comment 1 Carl George 2017-12-01 22:00:37 UTC
I'm not real good with autotools, but perhaps the issue is lua-5.3.0-autotoolize.patch creates a configure.ac file with 5.3.0 hard coded.

$ grep '5\.3\.0' lua-5.3.0-autotoolize.patch 
+AC_INIT([lua], [5.3.0], [https://bugzilla.redhat.com/], [lua-at], [http://www.lua.org])

I didn't try a proper rebase of the patch, but manually changing 5.3.0 to 5.3.4 in that patch file and rebuilding seems to correct the issue.

Comment 2 Tom "spot" Callaway 2017-12-04 17:24:18 UTC
Good catch Carl, that's exactly the issue. Fixed builds going now.

Comment 3 Fedora Update System 2017-12-04 17:42:26 UTC
lua-5.3.4-7.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5f69dd6cf3

Comment 4 Fedora Update System 2017-12-04 17:42:37 UTC
lua-5.3.4-7.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8d72e5d8c2

Comment 5 Fedora Update System 2017-12-04 17:42:43 UTC
lua-5.3.4-7.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1080b160b3

Comment 6 Fedora Update System 2017-12-05 02:54:01 UTC
lua-5.3.4-7.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1080b160b3

Comment 7 Fedora Update System 2017-12-08 23:27:47 UTC
lua-5.3.4-7.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8d72e5d8c2

Comment 8 Fedora Update System 2017-12-09 00:03:00 UTC
lua-5.3.4-7.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5f69dd6cf3

Comment 9 Fedora Update System 2017-12-12 11:22:51 UTC
lua-5.3.4-7.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2017-12-12 13:43:25 UTC
lua-5.3.4-7.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2017-12-12 14:40:22 UTC
lua-5.3.4-7.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.