Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519822 - [3.6] S2I behavior change between OCP 3.4 (3.4.1.24) and 3.5 (3.5.5.31.24) with regards to symlinks
Summary: [3.6] S2I behavior change between OCP 3.4 (3.4.1.24) and 3.5 (3.5.5.31.24) wi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.6.z
Assignee: Jim Minter
QA Contact: wewang
URL:
Whiteboard:
Depends On: 1506173
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-01 13:58 UTC by Carsten Lichy-Bittendorf
Modified: 2018-01-23 17:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A regression bug was reported whereby source-to-image builds would fail if the source repository filesystem contained a broken symlink (pointing to a non-existent item). This was resolved.
Clone Of:
Environment:
Last Closed: 2018-01-23 17:59:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0113 normal SHIPPED_LIVE OpenShift Container Platform 3.7 and 3.6 bug fix and enhancement update 2018-01-23 22:55:59 UTC

Description Carsten Lichy-Bittendorf 2017-12-01 13:58:23 UTC
Description of problem:

https://bugzilla.redhat.com/show_bug.cgi?id=1506173 was opened against OCP 3.5, but fixed with OCP 3.7 so please consider a backport of 
 - https://github.com/openshift/source-to-image/pull/820
 - https://github.com/openshift/origin/pull/17057
to OCP 3.5 as teh customer is still on OCP 3.5 and will stay on it for some more time.

Comment 5 Jim Minter 2017-12-19 20:50:54 UTC
https://github.com/openshift/ose/pull/976

Comment 7 wewang 2018-01-05 07:07:55 UTC
verified in 
openshift v3.5.5.31.24
kubernetes v1.5.2+43a9be4
etcd 3.1.0

steps:

steps:
$ oc new-app openshift/php~https://github.com/erreff/carsten -n wewang
$ oc logs bc/carsten -n wewang
Cloning "https://github.com/erreff/carsten" ...
	Commit:	352d2b6c173d63b7a5eb859ad6a1924a4cd506fe (add bad link)
	Author:	root <root@cpyi0013.net-courrier.extra.laposte.fr>
	Date:	Tue Oct 24 18:07:29 2017 +0200
---> Installing application source...
Pushing image 172.30.134.63:5000/wewang/carsten:latest ...
Pushed 0/6 layers, 6% complete
Pushed 1/6 layers, 18% complete
Pushed 2/6 layers, 36% complete
Pushed 3/6 layers, 53% complete
Pushed 4/6 layers, 77% complete
Pushed 5/6 layers, 100% complete
Pushed 6/6 layers, 100% complete
Push successful
[wewang@wangwen ~]$ oc get builds
NAME        TYPE      FROM          STATUS     STARTED          DURATION
carsten-1   Source    Git@352d2b6   Complete   18 minutes ago   32s

Comment 10 errata-xmlrpc 2018-01-23 17:59:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0113


Note You need to log in before you can comment on or make changes to this bug.