Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519808 - View archive link for default and metrics pods redirects to wrong kibana url
Summary: View archive link for default and metrics pods redirects to wrong kibana url
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.6.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.6.z
Assignee: Jeff Cantrill
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-01 13:23 UTC by Rajnikant
Modified: 2018-03-16 14:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The annotation to identify the proper kibana instance to use for ops namespaces is being set regardless of if an OPS logging cluster is used or not Consequence: Users will be directed to non-existent service from the origin web console when trying to view operations logs Fix: For existing deployments, manually run 'oc annotate ns $NAMESPACE openshift.io/logging.ui.hostname-' for each affected namespace. New deployments will only have this annotation set by the installer if 'openshift_logging_use_ops' variable is set to true. Result: User's will be directed to the correct version of Kibana when viewing ops logs from the origin web console.
Clone Of:
Environment:
Last Closed: 2018-01-23 17:59:00 UTC


Attachments (Terms of Use)
openshift-infra pod, view archive link redirect to correct url (deleted)
2017-12-19 01:31 UTC, Junqi Zhao
no flags Details
pod under default project, view archive link redirect to correct url (deleted)
2017-12-19 04:04 UTC, Junqi Zhao
no flags Details
pod under openshift-infra project, view archive link redirect to correct url (deleted)
2017-12-19 04:05 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0113 normal SHIPPED_LIVE OpenShift Container Platform 3.7 and 3.6 bug fix and enhancement update 2018-01-23 22:55:59 UTC
Github openshift openshift-ansible pull 6363 None None None 2017-12-05 20:37:23 UTC
Github openshift openshift-ansible pull 6474 None None None 2017-12-13 22:04:27 UTC

Description Rajnikant 2017-12-01 13:23:44 UTC
Description of problem:

Customer did not install logging EFK using parameter "openshift_logging_use_ops", even then view archive link of default and metrics is redirecting to incorrect operational ops url "kibana-ops.test.example.com".

loggingPublicURL i.e logging.test.example.com

Version-Release number of selected component (if applicable):
v3.6.173.0.49

How reproducible:

Installation of logging EFK without logging ops

Steps to Reproduce:

1. Deploy logging EFK, do not use parameter "openshift_logging_use_ops"
2. check view archive link of default project it redirects to operational ops url kibana-ops.test.example.com

Actual results:

View Archive link of a pod log for (default, metrics) project redirects to kibana-ops.test.example.com, where as loggingPublicURL=logging.test.example.com

Expected results:

As logging ops is not installed, view archive link should redirect to loggingPublicURL i.e logging.test.example.com

Additional info:
NA

Comment 1 Jeff Cantrill 2017-12-04 20:11:11 UTC
@Rajnikant  Can you please also provide a more specific version of Openshift and the output of the metrics namespace 'oc get project openshift-infra -o yaml'.  There is logic in the webconsole that controls where a user is directed

Comment 3 Jeff Cantrill 2017-12-05 15:19:51 UTC
The workaround is to edit the namespace and remove the annotation:

1. oc edit ns openshift-infra
2. delete annotatin: 'openshift.io/logging.ui.hostname'

Comment 4 Jeff Cantrill 2017-12-05 20:08:14 UTC
Easier workaround is:

oc annotate ns $NAMESPACE  openshift.io/logging.ui.hostname-

Comment 7 Jeff Cantrill 2017-12-06 15:59:09 UTC
Can you log that as a new issue?  This requires a change that is separate from this one.

Comment 10 Junqi Zhao 2017-12-19 01:30:06 UTC
View archive link for default and metrics pods now redirects to correct kibana url

Images:
logging-kibana/images/v3.6.173.0.89-1
logging-fluentd/images/v3.6.173.0.89-1
logging-auth-proxy/images/v3.6.173.0.89-1
logging-elasticsearch/images/v3.6.173.0.89-1
logging-curator/images/v3.6.173.0.89-1

Comment 11 Junqi Zhao 2017-12-19 01:31:06 UTC
Created attachment 1369747 [details]
openshift-infra pod, view archive link redirect to correct url

Comment 12 Junqi Zhao 2017-12-19 04:04:39 UTC
Created attachment 1369769 [details]
pod under default project, view archive link redirect to correct url

Comment 13 Junqi Zhao 2017-12-19 04:05:36 UTC
Created attachment 1369770 [details]
pod under openshift-infra project, view archive link redirect to correct url

Comment 16 errata-xmlrpc 2018-01-23 17:59:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0113

Comment 17 Bahaddin 2018-03-16 13:16:45 UTC
We just upgraded from 3.6.173 to 3.7.23 and faced exactly same issue.

openshift-infra namespace had the annotation with "kibana-ops"

Comment 18 Jeff Cantrill 2018-03-16 14:01:15 UTC
Please ref https://bugzilla.redhat.com/show_bug.cgi?id=1547348 for 3.7


Note You need to log in before you can comment on or make changes to this bug.