Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519756 - [downstream clone - 4.1.9] Cannot change dwh sampling scale with 'engine-setup --reconfigure-dwh-scale'
Summary: [downstream clone - 4.1.9] Cannot change dwh sampling scale with 'engine-setu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 4.1.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.1.9
: ---
Assignee: Ido Rosenzwig
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On: 1474570
Blocks: 1532508
TreeView+ depends on / blocked
 
Reported: 2017-12-01 12:02 UTC by rhev-integ
Modified: 2018-01-24 14:43 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of: 1474570
Environment:
Last Closed: 2018-01-24 14:43:05 UTC
oVirt Team: Integration


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84674 master MERGED Revert "packaging: setup: Configure scale only on new database" 2017-12-01 12:03:35 UTC
oVirt gerrit 84676 ovirt-engine-dwh-4.1 MERGED Revert "packaging: setup: Configure scale only on new database" 2017-12-01 12:03:35 UTC
Red Hat Knowledge Base (Solution) 3178721 None None None 2017-12-01 12:03:35 UTC
Red Hat Product Errata RHBA-2018:0133 normal SHIPPED_LIVE rhevm-dwh 4.1.9 bug fix update 2018-01-24 19:38:42 UTC

Description rhev-integ 2017-12-01 12:02:41 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1474570 +++
======================================================================

Description of problem:

The "engine-setup --reconfigure-dwh-scale" doesn't seem to ask user about changing for sampling scale setup from Basic to Full and vice versa.  

Version-Release number of selected component (if applicable):

Problem seen on ovirt 4.1.x and 4.0.x

ovirt-engine-4.1.3.5-0.1.el7.noarch
ovirt-engine-dwh-4.1.1-1.el7ev.noarch
ovirt-engine-dwh-setup-4.1.1-1.el7ev.noarch

ovirt-engine-4.0.7.4-0.1.el7ev.noarch
ovirt-engine-dwh-4.0.7-2.el7ev.noarch
ovirt-engine-dwh-setup-4.0.7-2.el7ev.noarch

How reproducible:

100% 

Steps to Reproduce:
1. Issue:  engine-setup --reconfigure-dwh-scale
   
Actual results:

   User will NOT be asked about sampling scale

~~~
    --== MISC CONFIGURATION ==--
         
          Please choose Data Warehouse sampling scale:
          (1) Basic
          (2) Full
          (1, 2)[1]: 
~~~         

Expected results:

Should ask user if they setting sampling scale.


Additional info:

Seems like broken due to BZ https://bugzilla.redhat.com/show_bug.cgi?id=1365427

(Originally by Bimal Chollera)

Comment 3 rhev-integ 2017-12-01 12:02:53 UTC
Can you provide the manual steps to reconfiguare the dwh to full collection?

(Originally by ylavi)

Comment 4 rhev-integ 2017-12-01 12:02:58 UTC
A workaround for this issue will be to add a conf file to ovirt-engine-dwhd.conf.d/
with a prefix greater then 10, like  99-my-scale.conf.

Add to the file the following lines:
DWH_TABLES_KEEP_SAMPLES=24
DWH_TABLES_KEEP_HOURLY=1440
DWH_TABLES_KEEP_DAILY=43800

and restart ovirt-engine-dwhd service

(Originally by Shirly Radco)

Comment 5 rhev-integ 2017-12-01 12:03:03 UTC
Can you please pass the info in comment 3 to the customer?
Can you create a KBase with this info?

(Originally by ylavi)

Comment 7 rhev-integ 2017-12-01 12:03:12 UTC
Ido, is this going to be in 4.2.0?

(Originally by Yaniv Kaul)

Comment 8 rhev-integ 2017-12-01 12:03:16 UTC
Yes. Sent a patch.

(Originally by Ido Rosenzwig)

Comment 9 rhev-integ 2017-12-01 12:03:21 UTC
Do we want this fix in 4.1 also ?

(Originally by Ido Rosenzwig)

Comment 10 rhev-integ 2017-12-01 12:03:25 UTC
The fix for this bug was to revert the patch for https://bugzilla.redhat.com/1365427

The author decided to show the question to the user only when a new database is created, what broke the --reconfigure-dwh-scale option.

https://bugzilla.redhat.com/show_bug.cgi?id=1365427#c2

(Originally by Ido Rosenzwig)

Comment 11 Lukas Svaty 2018-01-19 13:42:46 UTC
verified in ovirt-engine-dwh-4.1.9-1.el7ev.noarch

Comment 14 errata-xmlrpc 2018-01-24 14:43:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0133


Note You need to log in before you can comment on or make changes to this bug.