Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519706 - [3.6.1 REF]Shouldn't show .operations index in non-ops kibana
Summary: [3.6.1 REF]Shouldn't show .operations index in non-ops kibana
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.6.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.6.z
Assignee: Jeff Cantrill
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-01 09:06 UTC by Anping Li
Modified: 2018-01-23 17:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Don't display an '.operations' index-mapping in a non-ops ES cluster Reason: Operations indices will never exist in a non-ops ES cluster Result: The index-mapping is no longer visible.
Clone Of:
: 1519709 (view as bug list)
Environment:
Last Closed: 2018-01-23 17:59:00 UTC


Attachments (Terms of Use)
enabled ops cluster,kibana UI, there is not .operations index in non-ops kibana UI (deleted)
2017-12-18 02:43 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0113 normal SHIPPED_LIVE OpenShift Container Platform 3.7 and 3.6 bug fix and enhancement update 2018-01-23 22:55:59 UTC
Github openshift origin-aggregated-logging pull 844 None None None 2017-12-12 14:59:45 UTC

Description Anping Li 2017-12-01 09:06:59 UTC
Description of problem:
When ops is enabled, there is still a .operations index in non-ops kibana, when we click the .operations index, the kibana was tring to search records. that is wrong. We should use ops kibana to view operation logs.  the .operations index should be deleted in non-ops elasticsearch and kibana

Version-Release number of selected component (if applicable):
logging-elasticsearch/images/v3.6.173.0.63-12
logging-elasticsearch/images/v3.6.173.0.63-12
logging-auth-proxy/images/v3.6.173.0.63-11
logging-fluentd/images/v3.6.173.0.63-11

How reproducible:
always

Steps to Reproduce:
1.  Deploy logging and enable ops elasticsearch

openshift_logging_install_logging=true
openshift_logging_image_prefix=registry.example.com/openshift3/
openshift_logging_namespace=logging
openshift_logging_es_cluster_size=1
openshift_logging_es_memory_limit=1Gi

openshift_logging_use_ops=true
openshift_logging_es_ops_memory_limit=1Gi
openshift_logging_es_ops_cluster_size=1


openshift_logging_use_mux=true
openshift_logging_use_mux_client=true




2. cluster-admin search records in non-ops kibana

Actual results:
There is a .operations index.

Expected results:
There isn't .operations index.


Additional info:

Comment 1 Jeff Cantrill 2017-12-08 19:31:02 UTC
This should be resolved when https://bugzilla.redhat.com/show_bug.cgi?id=1519705 is resolved.

Comment 3 Junqi Zhao 2017-12-18 02:43:02 UTC
Enabled ops cluster, .operations index is not shown in non-ops kibana UI

Images:
logging-kibana/images/v3.6.173.0.89-1
logging-elasticsearch/images/v3.6.173.0.89-1
logging-fluentd/images/v3.6.173.0.89-1
logging-auth-proxy/images/v3.6.173.0.89-1
logging-curator/images/v3.6.173.0.89-1

elasticsearch-plugin in logging-elasticsearch image is openshift-elasticsearch-plugin-2.4.4.20 now
bash-4.2$ rpm -qa | grep elasticsearch-plugin
openshift-elasticsearch-plugin-2.4.4.20__redhat_1-1.el7.noarch

Comment 4 Junqi Zhao 2017-12-18 02:43:55 UTC
Created attachment 1369250 [details]
enabled ops cluster,kibana UI, there is not .operations index in non-ops kibana UI

Comment 7 errata-xmlrpc 2018-01-23 17:59:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0113


Note You need to log in before you can comment on or make changes to this bug.