Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519705 - [3.6.1] No document under .all index for non-ops kibana
Summary: [3.6.1] No document under .all index for non-ops kibana
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.6.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.6.z
Assignee: Jeff Cantrill
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On: 1519694
Blocks: 1526287
TreeView+ depends on / blocked
 
Reported: 2017-12-01 09:04 UTC by Anping Li
Modified: 2018-01-23 17:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Trying to alias an index that does not exist Consequence: Bulk alias operation fails. Fix: Only alias .operations if there is at least one .operations index Result: .all will be an alias for all indices
Clone Of: 1519694
: 1526287 (view as bug list)
Environment:
Last Closed: 2018-01-23 17:59:00 UTC


Attachments (Terms of Use)
enabled ops cluster,kibana UI, there are logs under .all index (deleted)
2017-12-18 01:09 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0113 normal SHIPPED_LIVE OpenShift Container Platform 3.7 and 3.6 bug fix and enhancement update 2018-01-23 22:55:59 UTC
Github fabric8io openshift-elasticsearch-plugin pull 115 None None None 2017-12-04 22:08:45 UTC
Github openshift origin-aggregated-logging pull 835 None None None 2017-12-08 20:30:24 UTC
Github openshift origin-aggregated-logging pull 844 None None None 2017-12-12 14:59:27 UTC

Description Anping Li 2017-12-01 09:04:27 UTC
Description of problem:

No document under .all index for non-ops kibana when ops is enabled.


Version-Release number of selected component (if applicable):
logging-elasticsearch/images/v3.6.173.0.63-12
logging-elasticsearch/images/v3.6.173.0.63-12
logging-auth-proxy/images/v3.6.173.0.63-11
logging-fluentd/images/v3.6.173.0.63-11


How reproducible:
always

Steps to Reproduce:
1.  Deploy logging and enable ops elasticsearch

openshift_logging_install_logging=true
openshift_logging_image_prefix=registry.example.com/openshift3/
openshift_logging_namespace=logging
openshift_logging_es_cluster_size=1
openshift_logging_es_memory_limit=1Gi

openshift_logging_use_ops=true
openshift_logging_es_ops_memory_limit=1Gi
openshift_logging_es_ops_cluster_size=1


openshift_logging_use_mux=true
openshift_logging_use_mux_client=true




2. cluster-admin search records in non-ops kibana


Actual results:
No records in .all index 

Expected results:
.all index should include records from all projects

Additional info:

Comment 1 Jeff Cantrill 2017-12-04 21:30:22 UTC
This occurs because there is no .operation index and we artificially add '.operations' to the projects to be aliased.  The bulk alias then fails because the index does not exist.  We will need to fix by checking for any indices and only adding .operations if we have a matching index.

Comment 2 Jeff Cantrill 2017-12-04 22:09:13 UTC
Sample error message from logs:

[2017-12-04 21:02:58,033][ERROR][io.fabric8.elasticsearch.plugin.kibana.KibanaSeed] Error executing Alias request
[.operations.*] IndexNotFoundException[no such index]

Comment 3 openshift-github-bot 2017-12-11 23:06:43 UTC
Commits pushed to master at https://github.com/openshift/origin-aggregated-logging

https://github.com/openshift/origin-aggregated-logging/commit/b2af1d20ec47ff9e9cd0eff846697d5214b5ca67
bug 1519705. bump openshift-elasticsearch-plugin-2.4.4.20 and build if necessary

https://github.com/openshift/origin-aggregated-logging/commit/4c5ca915194478a393b78b383464789d52804e9f
Merge pull request #835 from jcantrill/bump_244_20

Automatic merge from submit-queue.

bug 1519705. bump openshift-elasticsearch-plugin-2.4.4.20

Comment 5 Junqi Zhao 2017-12-18 01:08:28 UTC
Enabled ops cluster, there are logs under .all index for non-ops kibana, see the attached picture.

Images:
logging-kibana/images/v3.6.173.0.89-1
logging-elasticsearch/images/v3.6.173.0.89-1
logging-fluentd/images/v3.6.173.0.89-1
logging-auth-proxy/images/v3.6.173.0.89-1
logging-curator/images/v3.6.173.0.89-1

elasticsearch-plugin in logging-elasticsearch image is openshift-elasticsearch-plugin-2.4.4.20 now
bash-4.2$ rpm -qa | grep elasticsearch-plugin
openshift-elasticsearch-plugin-2.4.4.20__redhat_1-1.el7.noarch

Comment 6 Junqi Zhao 2017-12-18 01:09:21 UTC
Created attachment 1369217 [details]
enabled ops cluster,kibana UI, there are logs under .all index

Comment 9 errata-xmlrpc 2018-01-23 17:59:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0113


Note You need to log in before you can comment on or make changes to this bug.