Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519563 (ovs2.9update) - Request to update OVS to 2.9 in OSP 13
Summary: Request to update OVS to 2.9 in OSP 13
Keywords:
Status: CLOSED ERRATA
Alias: ovs2.9update
Product: Red Hat OpenStack
Classification: Red Hat
Component: openvswitch
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Timothy Redaelli
QA Contact: Toni Freger
URL:
Whiteboard:
: 1468331 1489045 (view as bug list)
Depends On:
Blocks: osp13ovn 1560717
TreeView+ depends on / blocked
 
Reported: 2017-11-30 22:19 UTC by Assaf Muller
Modified: 2018-06-27 13:41 UTC (History)
11 users (show)

Fixed In Version: openvswitch-2.9.0-0.1.20180108git8e3a28c.el7fdp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:40:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:41:00 UTC

Description Assaf Muller 2017-11-30 22:19:32 UTC
This RFE is to track a request to update from OVS 2.7 in OSP 12 to OVS 2.9 in OSP 13. Upstream OVN 2.9 packaged in OVS 2.9 is developed in tandem with OpenStack Queens, both are supposed to release within a 2 week delay. This RFE intends to track an effort that ensures that downstream OSP/OVS have the same 1:1 relationship between OVS 2.9 and OSP 13 (based on Queens).

Comment 2 Assaf Muller 2017-11-30 22:31:01 UTC
*** Bug 1468331 has been marked as a duplicate of this bug. ***

Comment 5 Daniel Alvarez Sanchez 2017-12-18 09:18:59 UTC
Official OVS 2.9 will be released around mid February 2018.
We'll use this BZ to track the effort once it's released.

Comment 6 Jon Schlueter 2017-12-18 10:02:36 UTC
Will it be release in parallel with Queens RC? 

https://releases.openstack.org/queens/schedule.html

Comment 7 Assaf Muller 2017-12-18 21:00:31 UTC
(In reply to Jon Schlueter from comment #6)
> Will it be release in parallel with Queens RC? 
> 
> https://releases.openstack.org/queens/schedule.html

Pretty much. That's challenging and something we've never done before.

We've always consumed a version of OVS that was 6 months behind the equivalent version of OpenStack. Now, with OVN, I argue that OVN (currently delivered within OVS), OVS becomes an OpenStack component, just like openstack-nova. That is because OVN is developed during an OpenStack cycle, and according to the OpenStack release schedule. Releasing OSP 13 with the previous version of OVN (2.8), would be like release OSP 13 with Nova from OSP 12.

What we're trying to do for this cycle is to consume OVS 2.9 with OSP 13. However, we won't have time to begin testing OVS 2.9 only after it's released, so we've set up a CI job that tests OSP with OVS from master. That way we hope to proactively deal with issues as they pop, so when OVS 2.9 is released, it'd already be tested and working.

Comment 9 Assaf Muller 2018-02-26 16:18:44 UTC
*** Bug 1489045 has been marked as a duplicate of this bug. ***

Comment 14 Toni Freger 2018-05-09 12:32:09 UTC
Verifying this bug, all networking squads working with latest openvswitch 2.9 version

Comment 16 errata-xmlrpc 2018-06-27 13:40:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.