Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519561 - [RFE] Add example for deleting a host in API Guide
Summary: [RFE] Add example for deleting a host in API Guide
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs API Guide
Version: 6.2.12
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: 6.3
Assignee: Michaela Slaninkova
QA Contact: Stephen Wadeley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 22:11 UTC by Scott Eldridge
Modified: 2018-12-06 20:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-06 07:55:58 UTC


Attachments (Terms of Use)

Description Scott Eldridge 2017-11-30 22:11:44 UTC
Upstream has an example to delete a host via API however we don't in our API guide.   Customer would like to see an example in our docs.

https://theforeman.org/2012/01/creating-new-host-using-foreman-api.html <- upstream 

TAM confirmed that this worked:

curl -H "Accept:application/json" -k -u $USER:$PASS -X DELETE https://satellite6.testlab.org/api/v2/hosts/$FQDNOFHOSTTODELETE

Deletes the host cleanly in Satellite 6.2.12

Rich Jerrido said via email list that the -H should not be needed since we are not passing a payload.

Comment 1 Andrew Dahms 2018-02-27 12:25:11 UTC
Assigning to Misa for review.


Note You need to log in before you can comment on or make changes to this bug.