Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519551 - Azure Blob DIsk Smartstate Analysis shows No XML returned for category [software] with NTFS Fixup Error
Summary: Azure Blob DIsk Smartstate Analysis shows No XML returned for category [softw...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: cfme-future
Assignee: Jerry Keselman
QA Contact: Satyajit Bulage
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 21:30 UTC by Jerry Keselman
Modified: 2018-12-11 16:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-11 16:54:14 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)
Snippet of evm.log file showing the issue. (deleted)
2017-11-30 21:30 UTC, Jerry Keselman
no flags Details
Another log snippet showing the error. (deleted)
2017-11-30 21:31 UTC, Jerry Keselman
no flags Details

Description Jerry Keselman 2017-11-30 21:30:36 UTC
Created attachment 1361264 [details]
Snippet of evm.log file showing the issue.

Description of problem: On certain Azure Blob Disk Windows Instances, the following error is written to the log during Smartstate Analysis:

ERROR -- : MIQ(NTFS::IndexRecordHeader.initialize) Invalid Index Record Header because: <NTFS Fixup Error: fixup signature:<22> does not match signature[8]=<18>.

Subsequently the scans continue, but the error message MIQ(ManageIQ::Providers::Azure::CloudManager::Vm#scan_via_miq_vm) Error: No XML returned for category [software] 
is written to the log.  

The scans give the impression of succeeding, but the applications at the very least are not processed correctly.


Version-Release number of selected component (if applicable):


How reproducible: Occasionally


Steps to Reproduce:
1. Run smartstate against certain Azure Windows Blob Disk Instances.   See the attached log files for examples.
2.
3.

Actual results:
Scan is not entirely successful.

Expected results:
Scan is successful.

Additional info:
Two log snippets will be attached.

Comment 2 Jerry Keselman 2017-11-30 21:31:28 UTC
Created attachment 1361266 [details]
Another log snippet showing the error.

Another log snippet showing the error on a different Instance.

Comment 3 Jerry Keselman 2017-11-30 21:46:54 UTC
This issue is based on a log attached to the BZ https://bugzilla.redhat.com/show_bug.cgi?id=1508154 which shows several issues which now each have their own BZs.


Note You need to log in before you can comment on or make changes to this bug.