Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519530 - Server Error when displaying Container project [NEEDINFO]
Summary: Server Error when displaying Container project
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Ari Zellner
QA Contact: Einat Pacifici
URL:
Whiteboard:
: 1519529 (view as bug list)
Depends On:
Blocks: 1525148
TreeView+ depends on / blocked
 
Reported: 2017-11-30 20:33 UTC by Jeff Warnica
Modified: 2018-06-21 20:58 UTC (History)
9 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1525148 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:58:26 UTC
Category: Bug
Cloudforms Team: Container Management
pzagalsk: needinfo? (juwatts)


Attachments (Terms of Use)

Description Jeff Warnica 2017-11-30 20:33:04 UTC
Description of problem:

Server Error "popup" when navigating to OSE project:

""""
URL /container_dashboard/project_data/99000000000001

Status 500 Internal Server Error

Content-Type text/html; charset=utf-8

Data undefined method `/' for nil:NilClass [container_dashboard/project_data]
"""

Version-Release number of selected component (if applicable):
5.9.0.11.20171127204214_e316988

How reproducible:
on one, but not all, appliances. Unkonwn

Steps to Reproduce:
1. Navigate to Compute->Container->Projects
2. Click on any project
3. Project page half loads

Actual results:
"Popup" with error

Expected results:
No error

Additional info:

This error is generated with all projects (including those from the lab); it is not created on the appliances mostly doing DB things.

Stack trace:

[----] I, [2017-11-30T15:24:16.000765 #26352:4eb0a9c]  INFO -- : Started GET "/static/notification_drawer/notification-subheading.html" for 70.191.57.42 at 2017-11-30 15:24:16 -0500
[----] I, [2017-11-30T15:24:16.019073 #26352:4eb0a9c]  INFO -- : Processing by StaticController#show as HTML
[----] I, [2017-11-30T15:24:16.019208 #26352:4eb0a9c]  INFO -- :   Parameters: {"id"=>"notification_drawer/notification-subheading.html"}
[----] I, [2017-11-30T15:24:16.021522 #26352:4eb0a9c]  INFO -- :   Rendering /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/static/notification_drawer/notificati
on-subheading.html.haml
[----] I, [2017-11-30T15:24:16.023838 #26352:4eb0a9c]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/static/notification_drawer/notificatio
n-subheading.html.haml (2.2ms)
[----] I, [2017-11-30T15:24:16.024157 #26352:4eb0a9c]  INFO -- : Completed 200 OK in 5ms (Views: 4.2ms | ActiveRecord: 0.0ms)
[----] F, [2017-11-30T15:24:16.488114 #26336:4eb4ae8] FATAL -- : Error caught: [NoMethodError] undefined method `/' for nil:NilClass
/opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/services/container_service_mixin.rb:73:in `utilization_data'
/opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/services/container_service_mixin.rb:182:in `hourly_utilization'
/opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/services/container_project_dashboard_service.rb:57:in `project_utilization'
/opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/services/container_project_dashboard_service.rb:16:in `all_data'
/opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/controllers/container_dashboard_controller.rb:63:in `collect_project_data'
/opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/controllers/container_dashboard_controller.rb:31:in `project_data'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_controller/metal/basic_implicit_render.rb:4:in `send_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/abstract_controller/base.rb:188:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_controller/metal/rendering.rb:30:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/abstract_controller/callbacks.rb:20:in `block in process_action'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:126:in `call'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:506:in `block (2 levels) in compile'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:455:in `call'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:101:in `__run_callbacks__'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:750:in `_run_process_action_callbacks'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:90:in `run_callbacks'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/abstract_controller/callbacks.rb:19:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_controller/metal/rescue.rb:20:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_controller/metal/instrumentation.rb:32:in `block in process_action'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/notifications.rb:164:in `block in instrument'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/notifications/instrumenter.rb:21:in `instrument'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/notifications.rb:164:in `instrument'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_controller/metal/instrumentation.rb:30:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_controller/metal/params_wrapper.rb:248:in `process_action'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/railties/controller_runtime.rb:18:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/abstract_controller/base.rb:126:in `process'
/opt/rh/cfme-gemset/gems/actionview-5.0.6/lib/action_view/rendering.rb:30:in `process'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_controller/metal.rb:190:in `dispatch'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_controller/metal.rb:262:in `dispatch'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/routing/route_set.rb:50:in `dispatch'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/routing/route_set.rb:32:in `serve'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/journey/router.rb:39:in `block in serve'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/journey/router.rb:26:in `each'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/journey/router.rb:26:in `serve'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/routing/route_set.rb:727:in `call'
/opt/rh/cfme-gemset/gems/secure_headers-3.0.3/lib/secure_headers/middleware.rb:10:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.3/lib/rack/etag.rb:25:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.3/lib/rack/conditional_get.rb:25:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.3/lib/rack/head.rb:12:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.3/lib/rack/session/abstract/id.rb:232:in `context'
/opt/rh/cfme-gemset/gems/rack-2.0.3/lib/rack/session/abstract/id.rb:226:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/middleware/cookies.rb:613:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/middleware/callbacks.rb:38:in `block in call'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:97:in `__run_callbacks__'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:750:in `_run_call_callbacks'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:90:in `run_callbacks'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/middleware/callbacks.rb:36:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/middleware/remote_ip.rb:79:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/middleware/debug_exceptions.rb:49:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/middleware/show_exceptions.rb:31:in `call'
/opt/rh/cfme-gemset/gems/railties-5.0.6/lib/rails/rack/logger.rb:36:in `call_app'
/opt/rh/cfme-gemset/gems/railties-5.0.6/lib/rails/rack/logger.rb:26:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/middleware/request_id.rb:24:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.3/lib/rack/method_override.rb:22:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.3/lib/rack/runtime.rb:22:in `call'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/cache/strategy/local_cache_middleware.rb:28:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/middleware/executor.rb:12:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.3/lib/rack/sendfile.rb:111:in `call'
/opt/rh/cfme-gemset/gems/railties-5.0.6/lib/rails/engine.rb:522:in `call'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/puma-3.7.1/lib/puma/configuration.rb:232:in `call'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/puma-3.7.1/lib/puma/server.rb:578:in `handle_request'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/puma-3.7.1/lib/puma/server.rb:415:in `process_client'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/puma-3.7.1/lib/puma/server.rb:275:in `block in run'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/puma-3.7.1/lib/puma/thread_pool.rb:120:in `block in spawn_thread'
[----] I, [2017-11-30T15:24:16.491785 #26336:4eb4ae8]  INFO -- :   Rendering /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/exception.html.haml within layouts/application
[----] I, [2017-11-30T15:24:16.501590 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/_exception_contents.html.haml (6.7ms)
[----] I, [2017-11-30T15:24:16.501702 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/exception.html.haml within layouts/application (9.8ms)
[----] I, [2017-11-30T15:24:16.512653 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/_doctype.html.haml (0.0ms)
[----] I, [2017-11-30T15:24:16.517148 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/stylesheets/_template50.html.haml (1.6ms)
[----] I, [2017-11-30T15:24:16.517965 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/_i18n_js.html.haml (0.0ms)
[----] I, [2017-11-30T15:24:16.537396 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/_about_modal.html.haml (7.6ms)
[----] I, [2017-11-30T15:24:16.587982 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/_user_options.html.haml (18.5ms)
[----] I, [2017-11-30T15:24:16.592279 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/_spinner.html.haml (3.3ms)
[----] I, [2017-11-30T15:24:16.595308 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/_lightbox_panel.html.haml (2.1ms)
[----] I, [2017-11-30T15:24:16.600118 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/_notifications_drawer.html.haml (3.9ms)
[----] I, [2017-11-30T15:24:16.603129 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/_toast_list.html.haml (2.1ms)
[----] I, [2017-11-30T15:24:16.603276 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/_header.html.haml (84.1ms)
[----] I, [2017-11-30T15:24:16.686253 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/_vertical_navbar.html.haml (61.6ms)
[----] I, [2017-11-30T15:24:16.691159 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/_breadcrumbs.html.haml (3.7ms)
[----] I, [2017-11-30T15:24:16.691387 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/_center_div_no_listnav.html.haml (72.6ms)
[----] I, [2017-11-30T15:24:16.691572 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/_content.html.haml (87.4ms)
[----] I, [2017-11-30T15:24:16.701909 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/_adv_search.html.haml (6.2ms)
[----] I, [2017-11-30T15:24:16.702078 #26336:4eb4ae8]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-95eeffff337a/app/views/layouts/_footer.html.haml (9.6ms)
[----] I, [2017-11-30T15:24:16.702420 #26336:4eb4ae8]  INFO -- : Completed 500 Internal Server Error in 807ms (Views: 209.0ms | ActiveRecord: 75.0ms)

Comment 2 Jeff Warnica 2017-11-30 20:46:56 UTC
Correction: regardless of appliance, fails 100% of the time when "Container Services" count is > 0

Comment 4 Chris Pelland 2017-12-01 15:43:57 UTC
*** Bug 1519529 has been marked as a duplicate of this bug. ***

Comment 6 Pavel Zagalsky 2017-12-04 12:18:13 UTC
I encountered this issue but couldn't recreate it reliably. 
Justin encountered it as well. Maybe he can chime in on the issue as well

Comment 7 Nimrod Shneor 2017-12-04 12:44:04 UTC
This seems to be a very similar bug to https://bugzilla.redhat.com/show_bug.cgi?id=1519382 - both I cannot recreate..  Maybe try and give more info about the environments? 
Can you try and recreate the above bug too?


Note You need to log in before you can comment on or make changes to this bug.