Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519476 - VMware - Validation failed: error, Unexpected response returned from Providers, see log for details
Summary: VMware - Validation failed: error, Unexpected response returned from Provider...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: GA
: 5.7.4
Assignee: Brandon Dunne
QA Contact: Alex Newman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 18:32 UTC by Alex Newman
Modified: 2017-12-06 15:00 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-05 20:25:20 UTC
Category: ---
Cloudforms Team: VMware


Attachments (Terms of Use)

Description Alex Newman 2017-11-30 18:32:42 UTC
Created attachment 1361100 [details]
Logs

Description of problem:


Version-Release number of selected component (if applicable):
5.7.4.1.20171114202358_de8178a

How reproducible:
1/1

Steps to Reproduce:
1.add vcenters 5.5,6.0,6.5
2.
3.

Actual results:
5.5 works, 6.0 fails, 6.5 is added but unfleeced

Expected results:
All versions added and fleeced correctly

Additional info:
Issue not in 5.9.0.11

Comment 2 Adam Grare 2017-12-01 15:41:38 UTC
The connection error was:
WARN -- : MIQ(ManageIQ::Providers::Vmware::InfraManager#verify_credentials) #<HTTPClient::ConnectTimeoutError: execution expired>

Did you confirm the networking to this provider is okay?

Comment 3 Greg Blomquist 2017-12-01 15:44:02 UTC
The "Version" field above shows this happening in 5.7, and the opening comment confirms that.

Is this happening in any version of 5.9?

If this isn't in 5.9, why is this a blocker for 5.9?

(adding Alex as needinfo in hopes that he can answer the version question ... the blocker question probably has to go back to PM or Dajo)

Comment 4 Alex Newman 2017-12-01 15:59:58 UTC
Greg: This is not an issue in 5.9.0.11

Adam: The webclients for all three vCenters worked fine, as did the vCenters when added to 5.9.0.11 appliance at the same time.

Comment 7 Adam Grare 2017-12-01 19:35:15 UTC
So I was able to connect to the 6.0 provider you had locally by DNS name, and I was able to connect to it on the appliance by IP address but not by DNS name on the appliance.  This might be DNS related, Alex can you test adding those providers by IP address instead of DNS name?

Comment 9 Adam Grare 2017-12-04 17:18:06 UTC
Hm okay strange, I'm going to reassign to Appliance since there seem to be some DNS resolution issues.

Comment 11 Brandon Dunne 2017-12-04 19:17:44 UTC
Hi Alex, can you share the providers you were using so I can try with the same ones?

Comment 13 Brandon Dunne 2017-12-04 20:34:59 UTC
Hi Alex, I got the provider information from Adam.  I am not able to reproduce the problem described.  I assume that you are adding the vSphere, validating credentials, saving and waiting for the initial refresh to complete.

I downloaded the same appliance version and tried this on your appliance as well. 
 No errors were encountered in adding any of the providers.

Also, I'm assuming that by "unfleeced", you mean refreshed.  Is there anything else I need to do to reproduce the problem?

Comment 14 Alex Newman 2017-12-04 21:49:03 UTC
Correct assumptions Brandon. I have not been able to reproduce this issue. At this point I can only believe it was environmental and is no longer an issue.

Comment 15 Dave Johnson 2017-12-05 20:25:20 UTC
Closing for now per comment 14.  Please re-open if we get more information on this one.


Note You need to log in before you can comment on or make changes to this bug.