Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519391 - [UPDATES] galare-bundle fails to restart
Summary: [UPDATES] galare-bundle fails to restart
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director-images
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 12.0 (Pike)
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 16:39 UTC by Yurii Prokulevych
Modified: 2018-02-05 19:18 UTC (History)
13 users (show)

Fixed In Version: rhosp-director-images-12.0-20171129.1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 22:23:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Yurii Prokulevych 2017-11-30 16:39:14 UTC
Description of problem:
-----------------------
During minor update from 21.5 to 29.2 update process hanged on last controller.
Previous 2 controllers were updated successfully.
PCS's status report galera being in 'slave' status:

 Docker container set: galera-bundle [192.168.24.1:8787/rhosp12/openstack-mariadb-docker:pcmklatest]
   galera-bundle-0      (ocf::heartbeat:galera):        Slave controller-1
   galera-bundle-1      (ocf::heartbeat:galera):        Slave controller-0
   galera-bundle-2      (ocf::heartbeat:galera):        Stopped

After discussion with Michele and Damien the problem is due to udpate of pacemaker* rpms from 1.1.16-12.el7_4.4 to 1.1.16-12.el7_4.5.

So we need to make sure that images contain at least pacemaker*1.1.16-12.el7_4.5. Michele, Damien please correct me if I'm wrong.

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
rhosp-director-images-ipa-12.0-20171129.1.el7ost.noarch
openstack-tripleo-image-elements-7.0.1-1.el7ost.noarch
genisoimage-1.1.11-23.el7.x86_64
rhosp-director-images-12.0-20171129.1.el7ost.noarch
rhosp-director-images-12.0-20171121.2.el7ost.noarch
rhosp-director-images-ipa-12.0-20171121.2.el7ost.noarch
diskimage-builder-2.9.0-2.8f02569.el7ost.noarch

Steps to Reproduce:
-------------------
1. Install rhos with previous puddle (21.5)
2. Install latest repos (29.2)
3. Update uc
4. Upload latest images, setup repos on oc
5. Perform init-minor-update
6. Start update of controller nodes.

Actual results:
---------------
Updates hangs cuz galera is in 'slave' state on 2 of 3 controller nodes.

Comment 1 Michele Baldessari 2017-11-30 18:12:12 UTC
http://download-node-02.eng.bos.redhat.com/rcm-guest/puddles/OpenStack/12.0-RHEL-7/2017-11-29.2/ already has pcmk 1.1.16-12.el7_4.5. So marking this as TestOnly

Comment 3 Udi Shkalim 2017-12-13 12:03:12 UTC
Passed sanity tests

Comment 6 errata-xmlrpc 2017-12-13 22:23:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.