Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519332 - usertools installed by dpdk-devel instead of dpdk-tools
Summary: usertools installed by dpdk-devel instead of dpdk-tools
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dpdk
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Neil Horman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 15:37 UTC by Timothy Redaelli
Modified: 2017-11-30 17:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-30 17:38:37 UTC


Attachments (Terms of Use)
fix_usertools.patch (deleted)
2017-11-30 15:37 UTC, Timothy Redaelli
no flags Details | Diff

Description Timothy Redaelli 2017-11-30 15:37:25 UTC
Created attachment 1360975 [details]
fix_usertools.patch

Description of problem:
/usr/share/dpdk/usertools/* is installed by dpdk-devel, but it should be installed by dpdk-tools since that directory is required by dpdk-pmdinfo (symlink of /usr/share/dpdk/usertools/dpdk-pmdinfo.py)

Version-Release number of selected component (if applicable):
Tested on dpdk 17.11

How reproducible:
100%

Steps to Reproduce:
1. Install dpdk-tools without installing dpdk-devel
2. Try to launch dpdk-pmdinfo

Actual results:
You cannot launch dpdk-pmdinfo, since the symlink is broken

Expected results:
dpdk-pmdinfo works

Additional info:


Note You need to log in before you can comment on or make changes to this bug.