Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519329 - The RHV-M does not correctly report the actual disk size if the disks.
Summary: The RHV-M does not correctly report the actual disk size if the disks.
Keywords:
Status: CLOSED DUPLICATE of bug 1185782
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core
Version: 4.1.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Eyal Shenitzky
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 15:35 UTC by Roman Hodain
Modified: 2017-12-20 07:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-04 14:53:53 UTC
oVirt Team: Storage
amureini: ovirt-4.2?
rhodain: planning_ack?
rhodain: devel_ack?
rhodain: testing_ack?


Attachments (Terms of Use)

Description Roman Hodain 2017-11-30 15:35:28 UTC
Description of problem:
The RHV-M does not correctly report the actual disk size if the disks if the disk contain a snapshot.

Version-Release number of selected component (if applicable):
RHV 4.1.6

How reproducible:
100%

Steps to Reproduce:
1. create a VM with disk
2. Crate a template
3. Check the actual size 

Actual results:

show disk --parent-vm-name rhodain-ovirt42-01 --name rhodain-ovirt42-01_Disk1| grep size
actual_size                      : 1073741824
provisioned_size                 : 64424509440
size                             : 64424509440


select image_guid, image_group_id, parentid, vm_snapshot_id, size, actual_size, volume_type, volume_format from images JOIN disk_image_dynamic on image_guid=image_id where image_group_id in (select disk_id from base_disks where disk_alias ='rhodain-ovirt42-01_Disk1');
              image_guid              |            image_group_id            |               parentid               |            vm_snapshot_id            |    size     | actual_size | volume_type | volume_format 
--------------------------------------+--------------------------------------+--------------------------------------+--------------------------------------+-------------+-------------+-------------+---------------
 72191229-8ad3-4652-8884-e2866bde1586 | 08a3b551-0a01-48f9-86dc-b44024283ef6 | 00000000-0000-0000-0000-000000000000 | c5729bd9-06db-46c9-97f3-e6a4f6a2112e | 64424509440 |  1073741824 |           2 |             4
 8e42455c-d36e-45c7-b3e6-f5cd0cc5b60c | 08a3b551-0a01-48f9-86dc-b44024283ef6 | 72191229-8ad3-4652-8884-e2866bde1586 | 2bca3f38-ad2e-4a22-8cf1-ec9a0522db55 | 64424509440 |  1073741824 |           2 |             4
(2 rows)


lvs -o lv_name,vg_name,lv_size,tags| grep 08a3b551-0a01-48f9-86dc-b44024283ef6 | tr -s " "
 72191229-8ad3-4652-8884-e2866bde1586 26050f66-8486-4974-ba43-bc71b4d9652f 1.00g IU_08a3b551-0a01-48f9-86dc-b44024283ef6,MD_9,PU_00000000-0000-0000-0000-000000000000 
 8e42455c-d36e-45c7-b3e6-f5cd0cc5b60c 26050f66-8486-4974-ba43-bc71b4d9652f 1.00g IU_08a3b551-0a01-48f9-86dc-b44024283ef6,MD_117,PU_72191229-8ad3-4652-8884-e2866bde1586 



Expected results:
The sizes of the snapshot are summed up. In this case the actual size should be 2GB as there are 2 volumes in the chain. Each has 1GB in size. 

I understand that not all volumes can be summed up. For exmaple templates should be excluded as that woudl cause duplications, but all snapshots should be included. There is currently no way to figure out the sizes of the images.

Comment 1 Allon Mureinik 2017-12-03 17:38:49 UTC
Eyal - I believe you added an API to get this in 4.2?

Comment 2 Eyal Shenitzky 2017-12-04 14:42:50 UTC
Yes. 
The field that should supply the disk size including its snapshots is total_size.

Roman, please look at this field (I assume it will be easier using rest-API) and check if the size is correct.

Comment 3 Allon Mureinik 2017-12-04 14:53:53 UTC

*** This bug has been marked as a duplicate of bug 1185782 ***


Note You need to log in before you can comment on or make changes to this bug.