Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519322 - Dangling symlinks in /usr/lib64/dpdk-pmds
Summary: Dangling symlinks in /usr/lib64/dpdk-pmds
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dpdk
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Neil Horman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 15:25 UTC by Timothy Redaelli
Modified: 2017-11-30 17:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-30 17:38:44 UTC


Attachments (Terms of Use)
fix_pmd_symlinks.patch (deleted)
2017-11-30 15:25 UTC, Timothy Redaelli
no flags Details | Diff

Description Timothy Redaelli 2017-11-30 15:25:04 UTC
Created attachment 1360972 [details]
fix_pmd_symlinks.patch

Description of problem:
Any symlink in %{_libdir}/dpdk-pmds links to the related ".so" file (in /usr/lib64), but it should point insted to the ".so.[0-9]" file, since the ".so" file is installed by dpdk-devel package and not by dpdk package.

Version-Release number of selected component (if applicable):
Tested in dpdk 17.11, probably broken since dpdk-2.2.0-2

How reproducible:
100%

Steps to Reproduce:
1. Install dpdk without installing dpdk-devel
2. Do "ls -l /usr/lib64/dpdk-pmds"

Actual results:
Symlinks are broken

Expected results:
Symlinks are not broken

Additional info:
This prevent any software dynamically linked by dpdk to load, at runtime, the related pmd.
For example testpmd (installed in dpdk package) doesn't work correctly unless you install dpdk-devel.


Note You need to log in before you can comment on or make changes to this bug.