Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519307 - [RFE] Issue a warning when user is nearing physical capacity of VDO
Summary: [RFE] Issue a warning when user is nearing physical capacity of VDO
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kmod-kvdo
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: bjohnsto
QA Contact: Jakub Krysl
URL:
Whiteboard:
Depends On: 1601016
Blocks: 1517911 1548461
TreeView+ depends on / blocked
 
Reported: 2017-11-30 15:09 UTC by Jakub Krysl
Modified: 2018-12-28 15:43 UTC (History)
5 users (show)

Fixed In Version: 6.1.1.102
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1548461 (view as bug list)
Environment:
Last Closed: 2018-10-30 09:38:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3094 None None None 2018-10-30 09:39:26 UTC

Description Jakub Krysl 2017-11-30 15:09:36 UTC
Description of problem:
There is no warning when user fills vdo with data, instead he gets I/O errors right away. For comparison and inspiration this is how dm-thin handles this:

/var/log/messages:
[81469.069613] device-mapper: thin: 253:4: reached low water mark for data device: sending event.

This is mainly useful for thin provisioning as it gets admin enough time to increase physical size of the storage.

Version-Release number of selected component (if applicable):
kmod-kvdo-6.1.0.55-10

How reproducible:
100%

Steps to Reproduce:
1. create vdo
2. fill it with enough data to fill whole real physical size of VDO

Comment 5 Jakub Krysl 2018-10-03 07:51:21 UTC
Tested with kmod-kvdo-6.1.1.125-5.el7.x86_64 using 6G VDO on 10G drive. Filling VDO with dd oflag=direct, /var/log/messages:
Oct  2 17:13:39 storageqe-75 kernel: kvdo1:packerQ: compression is enabled
Oct  2 17:13:39 storageqe-75 UDS/vdodmeventd[14034]: INFO   (vdodmeventd/14034) VDO device vdo is now registered with dmeventd for monitoring
Oct  2 17:13:39 storageqe-75 lvm[13863]: Monitoring VDO pool vdo.
Oct  2 17:27:39 storageqe-75 lvm[13863]: WARNING: VDO pool vdo is now 80.69% full.
Oct  2 17:28:19 storageqe-75 lvm[13863]: WARNING: VDO pool vdo is now 85.25% full.
Oct  2 17:29:39 storageqe-75 lvm[13863]: WARNING: VDO pool vdo is now 90.64% full.
Oct  2 17:30:29 storageqe-75 lvm[13863]: WARNING: VDO pool vdo is now 96.07% full.

For comparison this is what LVM thinp does in the exactly same situtation (6G physical):

Oct  3 09:33:05 storageqe-75 kernel: device-mapper: thin: Data device (dm-2) discard unsupported: Disabling discard passdown.
Oct  3 09:33:05 storageqe-75 lvm[13863]: Monitoring thin pool vg-tpool-tpool.
Oct  3 09:35:05 storageqe-75 lvm[13863]: WARNING: Thin pool vg-tpool-tpool data is now 87.32% full.
Oct  3 09:35:15 storageqe-75 lvm[13863]: WARNING: Thin pool vg-tpool-tpool data is now 97.76% full.

Comment 7 errata-xmlrpc 2018-10-30 09:38:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3094


Note You need to log in before you can comment on or make changes to this bug.