Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519296 - Image triggers don't start Custom Builds in 3.6
Summary: Image triggers don't start Custom Builds in 3.6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.6.z
Assignee: Jim Minter
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 14:52 UTC by Vadim Rutkovsky
Modified: 2017-12-14 21:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: imagetrigger-controller was missing the permission to create custom Build objects. Consequence: builds with customStrategy and ImageStreamTag triggers were not started whenever the ImageStreamTag was updated. Fix: add permission to the imagetrigger-controller. Result: builds with customStrategy and ImageStreamTag triggers are now started when the ImageStreamTag is updated.
Clone Of:
Environment:
Last Closed: 2017-12-14 21:02:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3438 normal SHIPPED_LIVE OpenShift Container Platform 3.6 and 3.5 bug fix and enhancement update 2017-12-15 01:58:11 UTC

Description Vadim Rutkovsky 2017-11-30 14:52:06 UTC
Description of problem:
New builds with customStrategy and ImageStreamTag triggers are not started whenever imagestreamtag is updated.

See https://github.com/openshift/origin/issues/17074 https://github.com/openshift/origin/pull/17108

Version-Release number of selected component (if applicable):
v3.6.0+c4dd4cf

How reproducible:
Always

Steps to Reproduce:
1. Create a new imagestream, add a tag there
2. Create a new buildconfig with customStrategy
3. Set a trigger to the buildconfig to start a new build whenever imagestreamtag is updated
4. Update the tag on imagestream

Actual results:
No new builds are scheduled

Expected results:
A new build is scheduled

Additional info:
This works fine in 3.7 and needs to be backported in 3.6, as it blocks OSBS team to delived chained rebuilds feature

Comment 1 Ben Parees 2017-11-30 14:59:56 UTC
Jim please provide the backport to ose 3.6, thanks.

Comment 3 Jim Minter 2017-11-30 17:26:41 UTC
https://github.com/openshift/ose/pull/946

Comment 4 Clayton Coleman 2017-12-02 00:16:30 UTC
Can easily fix by updating the role on affected clusters.

Comment 6 wewang 2017-12-05 08:45:19 UTC
verified in released version:
openshift v3.6.173.0.83

steps : 
1. Create project wewang
2. Create  image stream
  $ oc import-image origin-wenwang --from='docker.io/wewang58/origin-custom-docker-builder' --confirm=true --insecure=true --all=true -n wewang
3. Create custom build
 $oc new-app -f https://raw.githubusercontent.com/openshift/origin/master/examples/sample-app/application-template-custombuild.json
4. Edit bc with new imagestram and tag
                        "from": {
                            "kind": "ImageStreamTag",
                            "name": "origin-wenwang:latest",
                            "namespace": "wewang"
                        }
5. will trigger new build automatically
[root@dhcp-128-91 ~]#  oc get builds
NAME                  TYPE      FROM      STATUS     STARTED         DURATION
ruby-sample-build-1   Custom    Git       Complete   6 minutes ago   56s
ruby-sample-build-2   Custom    Git       Complete   3 minutes ago   34s

Comment 9 errata-xmlrpc 2017-12-14 21:02:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3438


Note You need to log in before you can comment on or make changes to this bug.