Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519277 - [free-int] Core file generated by OCP 3.7
Summary: [free-int] Core file generated by OCP 3.7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.6.z
Assignee: Dan Mace
QA Contact: Wang Haoran
URL:
Whiteboard:
Depends On: 1486416
Blocks: 1525799
TreeView+ depends on / blocked
 
Reported: 2017-11-30 14:17 UTC by Dan Mace
Modified: 2018-01-26 01:18 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The Kubernetes resource quota controller had fatal a race condition. Consequence: The master controller process occasionally crashes, writes a stack dump, and restarts. Fix: I patched Kubernetes to resolve the race condition (https://github.com/kubernetes/kubernetes/pull/52092). Result: The crash no longer occurs.
Clone Of: 1486416
Environment:
Last Closed: 2018-01-23 17:58:09 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3318671 None None None 2018-01-26 01:18:22 UTC
Red Hat Product Errata RHBA-2018:0113 normal SHIPPED_LIVE OpenShift Container Platform 3.7 and 3.6 bug fix and enhancement update 2018-01-23 22:55:59 UTC

Comment 2 Dan Mace 2017-12-01 13:37:28 UTC
https://github.com/openshift/ose/pull/945

Comment 4 Dan Mace 2017-12-05 13:56:57 UTC
Fix is merged.

Comment 17 ge liu 2017-12-22 08:48:37 UTC
Could not reproduce this issue on ocp3.6, and we done a regression testing with  ocp:3.6.173.0.90 since the fix have been merged.

Comment 20 errata-xmlrpc 2018-01-23 17:58:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0113


Note You need to log in before you can comment on or make changes to this bug.