Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519227 - [RFE] RHV: Can't provision a VM from ISO, no images displayed
Summary: [RFE] RHV: Can't provision a VM from ISO, no images displayed
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.10.0
Assignee: Greg McCullough
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 12:45 UTC by Antonin Pagac
Modified: 2018-07-23 17:38 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-23 17:38:03 UTC
Category: ---
Cloudforms Team: CFME Core


Attachments (Terms of Use)

Description Antonin Pagac 2017-11-30 12:45:16 UTC
Description of problem:
When trying to provision a VM on RHV 4.1.5.2 using Provision Type: ISO, there's no ISO images displayed to choose from. I can see multiple ISO images on the RHV provider itself on its ISO domain.

Version-Release number of selected component (if applicable):
5.9.0.11.20171127204214_e316988

How reproducible:
Always

Steps to Reproduce:
1. Have an appliance with RHV 4.1 added
2. Navigate to Compute -> Infrastructure -> Virtual Machines, Lifecycle -> Provision VMs
3. Choose any template
4. Proceed to Catalog tab and choose Provision Type ISO

Actual results:
No ISO images displayed

Expected results:
ISO images displayed as I can see them on RHV ISO domain

Additional info:

Comment 3 Brandon Dunne 2017-11-30 15:16:18 UTC
Antonin,

Have you added the ISO datastore under Infrastructure / PXE and refreshed it?

Comment 5 Antonin Pagac 2017-12-01 11:13:04 UTC
Hi Brandon,

no I did not. I was just trying to do stuff during testathon without reading the documentation, so this is most probably not a bug.

Maybe we could add a note/warning for the user to alert him that he should first add the ISO datastore?

Comment 6 Antonin Pagac 2017-12-01 11:20:37 UTC
When I added ISO datastore and refreshed and then tried to create new VM, the ISO images are displayed fine.

Comment 7 Greg McCullough 2017-12-01 13:59:24 UTC
change to an RFE so PM can decide how/if they want to warn the user.


Note You need to log in before you can comment on or make changes to this bug.