Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1519222 - [RFE] missing data for some fields in openshift-based reports for multiple report sources [NEEDINFO]
Summary: [RFE] missing data for some fields in openshift-based reports for multiple re...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.8.0
Hardware: All
OS: All
high
high
Target Milestone: GA
: cfme-future
Assignee: Gregg Tanzillo
QA Contact: Einat Pacifici
URL:
Whiteboard:
Depends On:
Blocks: 1572700
TreeView+ depends on / blocked
 
Reported: 2017-11-30 12:31 UTC by Felix Dewaleyne
Modified: 2019-02-08 20:54 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-08 20:54:41 UTC
Category: ---
Cloudforms Team: CFME Core
jprause: needinfo? (gtanzill)
niroy: needinfo? (gtanzill)
niroy: needinfo? (gtanzill)


Attachments (Terms of Use)

Description Felix Dewaleyne 2017-11-30 12:31:54 UTC
Description of problem:
missing data for fields agianst openshift-based reports for multiple report sources

Version-Release number of selected component (if applicable):
5.8.2.3

How reproducible:
not attempted - consistent behaviour with customer.

Steps to Reproduce:
1.deploy openshift on top of openstack
2.set up c&u globally, confirm there is no issue against openshift
3.

Actual results:
despite data being pulled against openshift, reports show no value or 0 for a lot of fields ; here is the list of fields, grouped by report source :

	- performance - container :
		- CPU - Available (%)
		- CPU - Available (MHz)
		- Capacity - Total Space (B)
		- Capacity - Used Space (B)
		- Disk I/O - Avg (KBps)
		- Memory - Available (%)
		- Memory - Available (MB)

	- nodes :
		- Hardware Size On Disk
		- Hardware Allocated Disk Storage
		- Hardware Allocated Disk Storage

	- Performance - Container Nodes :
		- Disk I/O - Avg (KBps)	

	- Performance - ContainerProjects:
		- CPU - Usage Rate for Collected Intervals (%)
		- Capacity - Avg Free Space for Collected Intervals (B)
		- Capacity - Total Space (B)
		- Capacity - Used Space (B)
		- Memory - Total Allocated for Child VMs (MB)
		- Memory - Usage of Total Allocated (%)
		- Derived Vm Allocated Disk Storage
		- Derived Vm Count Total
		- Derived Vm Used Disk Storage 


Expected results:
correct values are displayed when using the fields, matching data that is seen in cloudforms

Additional info:
more info regarding the customer affected included in private notes.

Comment 5 Joe Vlcek 2017-12-08 21:46:19 UTC
I just wanted to post a progress update.

We've reproduced what the customer is observing when we use
their database from the case.

We are still investigating the cause.

Comment 6 Joe Vlcek 2017-12-11 18:12:42 UTC
Investigation indicates the relevant data is not being saved in the database during the refresh. Reassigning to the Providers team for them to investigate.


Note You need to log in before you can comment on or make changes to this bug.